7.5

CVE-2024-24549: Apache Tomcat: HTTP/2 header handling DoS

Modified
AliasesUBUNTU-CVE-2024-24549DEBIAN-CVE-2024-24549CGA-4fr2-xc2v-g7gh
Published 13-03-2024Last modified 29-10-2025

Vulnerability summary

CVE-2024-24549 is a high (CVSS 7.5) Improper Input Validation vulnerability in apache software foundation apache tomcat. EPSS estimates a 23.07% chance of exploitation in the next 30 days, higher than 97.7% of scored vulnerabilities.

Priority
Prioritisesevere

Severe, CVSS 7.5 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 23% (FIRST, 03-11-2026)

Source freshness unavailable

How is this decided?
CVSS score
7.5/10
010
High · v3.1 (CVE.org)
EPSS score
23.07%
0%100%
High · 0.00 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 18 · Related 11

Timeline

  1. 13-03-2024
    PublishedVulnerability first disclosed.
  2. 29-10-2025
    Last modifiedVulnerability information updated.

Description

Denial of Service due to improper input validation vulnerability for HTTP/2 requests in Apache Tomcat. When processing an HTTP/2 request, if the request exceeded any of the configured limits for headers, the associated HTTP/2 stream was not reset until after all of the headers had been processed.This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M16, from 10.1.0-M1 through 10.1.18, from 9.0.0-M1 through 9.0.85, from 8.5.0 through 8.5.98. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M17, 10.1.19, 9.0.86 or 8.5.99 which fix the issue.

CVSS metrics

7 scores · 6 sources · 2 versions

EPSS trend

Probability

23.07%

Chance of exploitation in the next 30 days

Percentile

98%

Versus all other CVEs

30-day change

No change 0.00 pp

From 23.07% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.

Debian3 products
  • tomcat10< 10.1.6-1+deb12u2 | < 10.1.20-1
  • tomcat9< 9.0.70-2
  • debian_linuxEOL10.0
Ubuntu3 products
  • tomcat10< 10.1.16-1ubuntu0.1~esm2
  • tomcat8< 8.5.39-1ubuntu1~18.04.3+esm5
  • tomcat9< 9.0.16-3ubuntu0.18.04.2+esm7 | < 9.0.31-1ubuntu0.9+esm2 | < 9.0.58-1ubuntu0.2+esm3 | < 9.0.70-2ubuntu0.1+esm2 | < 9.0.70-2ubuntu3
Apache1 product
  • tomcat≥ 8.5.0, < 8.5.99 | ≥ 9.0.0, < 9.0.86 | ≥ 10.1.0, < 10.1.19 | 11.0.0:milestone1 | 11.0.0:milestone10 | 11.0.0:milestone11 | 11.0.0:milestone12 | 11.0.0:milestone13 | 11.0.0:milestone14 | 11.0.0:milestone15 | 11.0.0:milestone16 | 11.0.0:milestone2 | 11.0.0:milestone3 | 11.0.0:milestone4 | 11.0.0:milestone5 | 11.0.0:milestone6 | 11.0.0:milestone7 | 11.0.0:milestone8 | 11.0.0:milestone9
Apache software foundation1 product
  • apache tomcat≥ 11.0.0-M1, ≤ 11.0.0-M16 | ≥ 10.1.0-M1, ≤ 10.1.18 | ≥ 9.0.0-M1, ≤ 9.0.85 | ≥ 8.5.0, ≤ 8.5.98
Chainguard1 product
  • tomcat-8.5.87All versions (No fix recorded)
Fedoraproject1 product
Org.apache.tomcat1 product
  • tomcat-coyote≥ 11.0.0-M1, < 11.0.0-M17 | ≥ 10.1.0-M1, < 10.1.19 | ≥ 9.0.0-M1, < 9.0.86 | ≥ 8.5.0, < 8.5.99
Org.apache.tomcat.embed1 product
  • tomcat-embed-core≥ 8.5.0, < 8.5.99 | ≥ 9.0.0-M1, < 9.0.86 | ≥ 10.1.0-M1, < 10.1.19 | ≥ 11.0.0-M1, < 11.0.0-M17

8 vendors · 12 products

References

20 links
Show all 20 references