CVE-2024-26143: Rails Possible XSS Vulnerability in Action Controller
Vulnerability summary
CVE-2024-26143 is a medium (CVSS 6.1) vulnerability in rails. EPSS estimates a 1.03% chance of exploitation in the next 30 days, higher than 63.8% of scored vulnerabilities. 3 public exploits are recorded.
Not severe (CVSS 6.1, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 4 · Related 4Timeline
- 27-02-2024PublishedVulnerability first disclosed.
- 13-02-2025Last modifiedVulnerability information updated.
Description
Rails is a web-application framework. There is a possible XSS vulnerability when using the translation helpers in Action Controller. Applications using translation methods like translate, or t on a controller, with a key ending in "_html", a :default key which contains untrusted user input, and the resulting string is used in a view, may be susceptible to an XSS vulnerability. The vulnerability is fixed in 7.1.3.1 and 7.0.8.1.
CVSS metrics
4 scores · 4 sources · 1 version- OSV · UbuntuEcosystem advisory · calculated6.1MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- OSV · RubygemsEcosystem advisory · calculated6.1MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- NVDNIST6.1MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS trend
Probability
1.03%
Chance of exploitation in the next 30 days
Percentile
64%
Versus all other CVEs
30-day change
No change 0.00 pp
From 1.03% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
3 foundRails
Maturity: poc
Ruby Advisory Db
Maturity: poc
Exploit Reference (discuss.rubyonrails.org)
Maturity: unknown
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, no authentication, user interaction (CVSS vector). Other conditions: not stated in public data.
RubyGems2 products
- actionpack≥ 7.0.0, < 7.0.8.1 | ≥ 7.1.0, < 7.1.3.1
- rails≥ 7.0.0, < 7.0.8.1 | ≥ 7.1.0, < 7.1.3.1
Rails1 product
- rails≥ 7.0.0, < 7.0.8.1 | ≥ 7.1.0, < 7.1.3.1
Rubyonrails1 product
- rails≥ 7.0.0, < 7.0.8.1 | ≥ 7.1.0, < 7.1.3.1
Ubuntu1 product
- railsAll versions (No fix recorded)
4 vendors · 5 products
References
11 links- github.com/rails/rails/security/advisories/GHSA-9822-6m93-xqf4X Refsource CONFIRMREPORTWEBExploitVendor Advisory
- github.com/rails/rails/commit/4c83b331092a79d58e4adffe4be5f250fa5782ccX Refsource MISCREPORTWEBPatch
- github.com/rails/rails/commit/5187a9ef51980ad1b8e81945ebe0462d28f84f9eX Refsource MISCREPORTWEBPatch
- discuss.rubyonrails.org/t/possible-xss-vulnerability-in-action-controller/84947X Refsource MISCREPORTWEBExploitVendor Advisory
- github.com/rubysec/ruby-advisory-db/blob/master/gems/actionpack/CVE-2024-26143.ymlX Refsource MISCREPORTWEBExploitThird Party Advisory
- security.netapp.com/advisory/ntap-20240510-0004/Third Party Advisory
- github.com/rails/railsPACKAGE