7.5

CVE-2024-26146: Possible Denial of Service Vulnerability in Rack Header Parsing

Analyzed
AliasesUBUNTU-CVE-2024-26146DEBIAN-CVE-2024-26146CGA-2x68-mf57-j578
Published 28-02-2024Last modified 13-02-2025

Vulnerability summary

CVE-2024-26146 is a high (CVSS 7.5) vulnerability in debian debian_linux. EPSS estimates a 2.00% chance of exploitation in the next 30 days, higher than 80.7% of scored vulnerabilities.

Priority
Routine

Not severe (CVSS 5.3, network access); no exploitation reported by the 5 checked sources

Source freshness unavailable

How is this decided?
CVSS score
7.5/10
010
High · v3.1 (NVD)
EPSS score
2.00%
0%100%
Low · 0.00 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 24 · Related 20

Timeline

  1. 28-02-2024
    PublishedVulnerability first disclosed.
  2. 13-02-2025
    Last modifiedVulnerability information updated.

Description

Rack is a modular Ruby web server interface. Carefully crafted headers can cause header parsing in Rack to take longer than expected resulting in a possible denial of service issue. Accept and Forwarded headers are impacted. Ruby 3.2 has mitigations for this problem, so Rack applications using Ruby 3.2 or newer are unaffected. This vulnerability is fixed in 2.0.9.4, 2.1.4.4, 2.2.8.1, and 3.0.9.1.

CVSS metrics

6 scores · 6 sources · 1 version

EPSS trend

Probability

2.00%

Chance of exploitation in the next 30 days

Percentile

81%

Versus all other CVEs

30-day change

No change 0.00 pp

From 2.00% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.

Chainguard6 products
  • kube-fluentd-operator< 1.18.2-r3
  • kube-fluentd-operator-compat< 1.18.2-r3
  • kube-fluentd-operator-default-config< 1.18.2-r3
  • kube-fluentd-operator-oci-entrypoint< 1.18.2-r3
  • ruby3.2-rack< 3.0.9.1-r0
Wolfi6 products
  • kube-fluentd-operator< 1.18.2-r3
  • kube-fluentd-operator-compat< 1.18.2-r3
  • kube-fluentd-operator-default-config< 1.18.2-r3
  • kube-fluentd-operator-oci-entrypoint< 1.18.2-r3
  • ruby3.2-rack< 3.0.9.1-r0
Debian2 products
  • ruby-rack< 2.2.6.4-1+deb12u1 | < 2.2.7-1.1
  • debian_linuxEOL10.0
Rack1 product
  • rack≥ 3.0.0, < 3.0.9.1 | < 2.0.9.4 | ≥ 0.4, < 2.0.9.4 | ≥ 2.1.0, < 2.1.4.4 | ≥ 2.2.0, < 2.2.8.1
RubyGems1 product
  • rack≥ 3.0.0, < 3.0.9.1 | ≥ 2.2.0, < 2.2.8.1 | ≥ 2.1.0, < 2.1.4.4 | < 2.0.9.4
Ubuntu1 product
  • ruby-rack< 1.5.2-3+deb8u3ubuntu1~esm8 | < 1.6.4-3ubuntu0.2+esm6 | < 1.6.4-4ubuntu0.2+esm6 | < 2.0.7-2ubuntu0.1+esm5 | < 2.1.4-5ubuntu1.1 | < 2.1.4-5ubuntu1+esm5 | < 2.2.7-1ubuntu0.1

6 vendors · 17 products

References

20 links
Show all 20 references