5.3

CVE-2024-29025: Netty HttpPostRequestDecoder can OOM

Analyzed
AliasesSUSE-SU-2024:1079-1SUSE-SU-2024:1079-2SUSE-SU-2024:2313-1
Published 25-03-2024Last modified 13-02-2025

Vulnerability summary

CVE-2024-29025 is a medium (CVSS 5.3) vulnerability in debian debian_linux. EPSS estimates a 1.38% chance of exploitation in the next 30 days, higher than 72.1% of scored vulnerabilities. 2 public exploits are recorded.

Priority
Routine

Not severe (CVSS 5.3, network access); no exploitation reported by the 5 checked sources

Source freshness unavailable

How is this decided?
CVSS score
5.3/10
010
Medium · v3.1 (CVE.org)
EPSS score
1.38%
0%100%
Low · 0.00 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits2github

Advisory lineage

Upstream 0 · Downstream 8 · Related 22

Timeline

  1. 25-03-2024
    PublishedVulnerability first disclosed.
  2. 13-02-2025
    Last modifiedVulnerability information updated.

Description

Netty is an asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. The `HttpPostRequestDecoder` can be tricked to accumulate data. While the decoder can store items on the disk if configured so, there are no limits to the number of fields the form can have, an attacher can send a chunked post consisting of many small fields that will be accumulated in the `bodyListHttpData` list. The decoder cumulates bytes in the `undecodedChunk` buffer until it can decode a field, this field can cumulate data without limits. This vulnerability is fixed in 4.1.108.Final.

CVSS metrics

7 scores · 7 sources · 1 version

EPSS trend

Probability

1.38%

Chance of exploitation in the next 30 days

Percentile

72%

Versus all other CVEs

30-day change

No change 0.00 pp

From 1.38% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

2 found
  • githubUnverified

    Netty

    Maturity: poc

  • githubUnverified

    F558B8Ea81Ec6505F1E9A6Ca283C9Ae3

    Maturity: poc

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.

Chainguard63 products
  • celeborn-0.5< 0.5.4-r26
  • cloudwatch-exporter< 0.15.5-r1
  • druid< 37.0.0-r8
  • elasticsearch-7< 7.17.20-r0
  • elasticsearch-7-iamguarded< 7.17.20-r0
Suse28 products
  • netty-tcnative&distro=SUSE Enterprise Storage 7.1< 2.0.65-150200.3.19.1
  • netty-tcnative&distro=SUSE Linux Enterprise High Performance Computing 15 SP2-LTSS< 2.0.65-150200.3.19.1
  • netty-tcnative&distro=SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS< 2.0.65-150200.3.19.1
  • netty-tcnative&distro=SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS< 2.0.65-150200.3.19.1
  • netty-tcnative&distro=SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS< 2.0.65-150200.3.19.1
Wolfi12 products
  • cloudwatch-exporter< 0.15.5-r1
  • druid< 37.0.0-r8
  • keycloak< 24.0.2-r1
  • opensearch-2< 2.13.0-r0
  • selenium< 4.19.0-r0
Opensuse7 products
  • netty-tcnative&distro=openSUSE Leap 15.5< 2.0.65-150200.3.19.1
  • netty-tcnative&distro=openSUSE Leap 15.6< 2.0.65-150200.3.19.1
  • netty3&distro=openSUSE Leap 15.5< 3.10.6-150200.3.10.1
  • netty3&distro=openSUSE Leap 15.6< 3.10.6-150200.3.10.1
  • netty3&distro=openSUSE Tumbleweed< 3.10.6-17.1
Debian2 products
  • netty< 1:4.1.33-1+deb10u5 | < 1:4.1.48-7+deb12u2 | < 1:4.1.48-10
  • debian_linuxEOL10.0
Io.netty1 product
  • netty-codec-http< 4.1.108.Final
Netty1 product
  • netty< 4.1.108.Final | < 4.1.108
Ubuntu1 product
  • netty< 1:4.0.34-1ubuntu0.1~esm2 | < 1:4.1.7-4ubuntu0.1+esm3 | < 1:4.1.45-1ubuntu0.1~esm2 | < 1:4.1.48-4+deb11u2ubuntu0.1~esm1

8 vendors · 115 products

References

17 links
Show all 17 references