CVE-2024-30260: Undici's Proxy-Authorization header not cleared on cross-origin redirect for dispatch, request, stream, pipeline
Vulnerability summary
CVE-2024-30260 is a medium (CVSS 4.3) Improper Authorization vulnerability in fedoraproject fedora. EPSS estimates a 0.73% chance of exploitation in the next 30 days, higher than 54.4% of scored vulnerabilities.
Not severe (CVSS 3.9, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 6 · Related 6Timeline
- 04-04-2024PublishedVulnerability first disclosed.
- 04-11-2025Last modifiedVulnerability information updated.
Description
Undici is an HTTP/1.1 client, written from scratch for Node.js. Undici cleared Authorization and Proxy-Authorization headers for `fetch()`, but did not clear them for `undici.request()`. This vulnerability was patched in version(s) 5.28.4 and 6.11.1.
CVSS metrics
5 scores · 5 sources · 1 version- CVE.orgCNA3.9LowCVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:LDiffers
- OSV · UbuntuEcosystem advisory · calculated4.3MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:L
- OSV · DebianEcosystem advisory · calculated4.3MediumCVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:L/I:L/A:L
- OSV · NpmEcosystem advisory · calculated3.9LowCVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:L/I:L/A:LDiffers
EPSS trend
Probability
0.73%
Chance of exploitation in the next 30 days
Percentile
54%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.73% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root cause- CWE-285Improper AuthorizationThe product does not perform or incorrectly performs an authorization check when an actor attempts to access a resource or perform an action.
- CWE-863Incorrect AuthorizationThe product performs an authorization check when an actor attempts to access a resource or perform an action, but it does not correctly perform the check.
Affected systems
Known conditions: network-reachable, administrative account, user interaction (CVSS vector). Other conditions: not stated in public data.
Debian1 product
- node-undiciAll versions (No fix recorded) | < 5.28.4+dfsg1+~cs23.12.11-1
Fedoraproject1 product
- fedoraEOL38 | 39 | 40
Nodejs1 product
- undici< 5.28.4 | ≥ 6.0.0, < 6.11.1
Npm1 product
- undici< 5.28.4 | ≥ 6.0.0, < 6.11.1
Opensuse1 product
- nodejs-electron&distro=openSUSE Tumbleweed< 28.2.10-2.1
Ubuntu1 product
- node-undiciAll versions (No fix recorded)
6 vendors · 6 products
References
18 links- github.com/nodejs/undici/security/advisories/GHSA-m4v8-wqvr-p9f7X Refsource CONFIRMREPORTWEBPatchVendor Advisory
- github.com/nodejs/undici/commit/64e3402da4e032e68de46acb52800c9a06aaea3fX Refsource MISCREPORTWEBPatch
- github.com/nodejs/undici/commit/6805746680d27a5369d7fb67bc05f95a28247d75X Refsource MISCREPORTWEBPatch
Show all 18 references
- github.com/nodejs/undiciPACKAGE