CVE-2024-3177: Bypassing mountable secrets policy imposed by the ServiceAccount admission plugin
Vulnerability summary
CVE-2024-3177 is a low (CVSS 2.7) Improper Input Validation vulnerability in kubernetes. EPSS estimates a 2.22% chance of exploitation in the next 30 days, higher than 82.7% of scored vulnerabilities.
Not severe (CVSS 2.7, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 6 · Related 37Timeline
- 22-04-2024PublishedVulnerability first disclosed.
- 10-09-2024Last modifiedVulnerability information updated.
Description
A security issue was discovered in Kubernetes where users may be able to launch containers that bypass the mountable secrets policy enforced by the ServiceAccount admission plugin when using containers, init containers, and ephemeral containers with the envFrom field populated. The policy ensures pods running with a service account may only reference secrets specified in the service account’s secrets field. Kubernetes clusters are only affected if the ServiceAccount admission plugin and the kubernetes.io/enforce-mountable-secrets annotation are used together with containers, init containers, and ephemeral containers with the envFrom field populated.
CVSS metrics
7 scores · 7 sources · 1 version- OSV · UbuntuEcosystem advisory · calculated2.7LowCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
- OSV · DebianEcosystem advisory · calculated2.7LowCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
- OSV · WolfiEcosystem advisory · calculated2.7LowCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
- OSV · GoEcosystem advisory · calculated2.7LowCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
- OSV · ChainguardEcosystem advisory · calculated2.7LowCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
- NVDNIST2.7LowCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N
EPSS trend
Probability
2.22%
Chance of exploitation in the next 30 days
Percentile
83%
Versus all other CVEs
30-day change
No change 0.00 pp
From 2.22% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, administrative account, no user interaction (CVSS vector). Other conditions: not stated in public data.
Chainguard20 products
- argo-cd-2.11All versions (No fix recorded)
- argocd-image-updater< 0.17.0-r1
- argocd-image-updater-fips< 0.17.0-r2
- aws-ebs-csi-driver< 1.30.0-r0
- aws-efs-csi-driver< 2.1.1-r0
Wolfi13 products
- argocd-image-updater< 0.17.0-r1
- aws-efs-csi-driver< 2.1.1-r0
- ip-masq-agent< 2.9.3-r10
- kubectl-1.28< 1.28.9-r0
- kubectl-1.28-default< 1.28.9-r0
Opensuse2 products
- kubernetes1.23&distro=openSUSE Leap 15.5< 1.23.17-150500.3.12.1
- kubernetes1.24&distro=openSUSE Leap 15.5< 1.24.17-150500.3.16.1
Suse2 products
- kubernetes1.23&distro=SUSE Linux Enterprise Module for Containers 15 SP5< 1.23.17-150500.3.12.1
- kubernetes1.24&distro=SUSE Linux Enterprise Module for Containers 15 SP5< 1.24.17-150500.3.16.1
Debian1 product
- kubernetes< 1.20.5+really1.20.2-1
K8s.io1 product
- kubernetes< 1.27.13 | ≥ 1.28.0, < 1.28.9 | ≥ 1.29.0, < 1.29.4
Kubernetes1 product
- kubernetes≤ 1.27.12 | v1.28.0 - v1.28.8 | v1.29.0 - v1.29.3
Ubuntu1 product
- kubernetesAll versions (No fix recorded)
8 vendors · 41 products
References
22 links- groups.google.com/g/kubernetes-security-announce/c/JxjHf7fkVd8/m/oVCzypyOAQAJMailing ListREPORTARTICLEWEB