CVE-2024-32474: Sentry's superuser cleartext password leaked in logs
Vulnerability summary
CVE-2024-32474 is a high (CVSS 7.3) Improper Output Neutralization for Logs vulnerability in getsentry sentry. EPSS estimates a 0.43% chance of exploitation in the next 30 days, higher than 37% of scored vulnerabilities.
Not severe (CVSS 7.3, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Timeline
- 18-04-2024PublishedVulnerability first disclosed.
- 02-08-2024Last modifiedVulnerability information updated.
Description
Sentry is an error tracking and performance monitoring platform. Prior to 24.4.1, when authenticating as a superuser to Sentry with a username and password, the password is leaked as cleartext in logs under the _event_: `auth-index.validate_superuser`. An attacker with access to the log data could use these leaked credentials to login to the Sentry system as superuser. Self-hosted users on affected versions should upgrade to 24.4.1 or later. Users can configure the logging level to exclude logs of the `INFO` level and only generate logs for levels at `WARNING` or more.
CVSS metrics
3 scores · 3 sources · 1 version- OSV · PypiEcosystem advisory · calculated7.3HighCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
- NVDNIST6.5MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:NDiffers
EPSS trend
Probability
0.43%
Chance of exploitation in the next 30 days
Percentile
37%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.43% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root cause- CWE-117Improper Output Neutralization for LogsThe product constructs a log message from external input, but it does not neutralize or incorrectly neutralizes special elements when the message is written to a log file.
- CWE-312Cleartext Storage of Sensitive InformationThe product stores sensitive information in cleartext within a resource that might be accessible to another control sphere.
Affected systems
Known conditions: network-reachable, low-privilege account, user interaction (CVSS vector). Other conditions: not stated in public data.
Getsentry1 product
- sentry≥ 24.3.0, < 24.4.1
PyPI1 product
- sentry≥ 24.3.0, < 24.4.1
Sentry1 product
- sentry≥ 24.3.0, < 24.4.1
3 vendors · 3 products
References
8 links- github.com/getsentry/sentry/security/advisories/GHSA-6cjm-4pxw-7xp9X Refsource CONFIRMWEBMitigationVendor Advisory
- github.com/getsentry/sentryPACKAGE
- pypi.org/project/sentryPACKAGE