6.5

CVE-2024-37891: Proxy-Authorization request header isn't stripped during cross-origin redirects in urllib3

Analyzed
AliasesMGASA-2024-0347SUSE-SU-2024:2320-1SUSE-SU-2024:2662-1
Published 17-06-2024Last modified 03-11-2025

Vulnerability summary

CVE-2024-37891 is a medium (CVSS 6.5) vulnerability in debian debian_linux. EPSS estimates a 1.14% chance of exploitation in the next 30 days, higher than 66.6% of scored vulnerabilities. 1 public exploit is recorded.

Priority
Routine

Not severe (CVSS 4.4, network access); no exploitation reported by the 5 checked sources

Source freshness unavailable

How is this decided?
CVSS score
6.5/10
010
Medium · v3.1 (NVD)
EPSS score
1.14%
0%100%
Low · 0.00 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits1reference

Advisory lineage

Upstream 0 · Downstream 14 · Related 43

Timeline

  1. 17-06-2024
    PublishedVulnerability first disclosed.
  2. 03-11-2025
    Last modifiedVulnerability information updated.

Description

urllib3 is a user-friendly HTTP client library for Python. When using urllib3's proxy support with `ProxyManager`, the `Proxy-Authorization` header is only sent to the configured proxy, as expected. However, when sending HTTP requests *without* using urllib3's proxy support, it's possible to accidentally configure the `Proxy-Authorization` header even though it won't have any effect as the request is not using a forwarding proxy or a tunneling proxy. In those cases, urllib3 doesn't treat the `Proxy-Authorization` HTTP header as one carrying authentication material and thus doesn't strip the header on cross-origin redirects. Because this is a highly unlikely scenario, we believe the severity of this vulnerability is low for almost all users. Out of an abundance of caution urllib3 will automatically strip the `Proxy-Authorization` header during cross-origin redirects to avoid the small chance that users are doing this on accident. Users should use urllib3's proxy support or disable automatic redirects to achieve safe processing of the `Proxy-Authorization` header, but we still decided to strip the header by default in order to further protect users who aren't using the correct approach. We believe the number of usages affected by this advisory is low. It requires all of the following to be true to be exploited: 1. Setting the `Proxy-Authorization` header without using urllib3's built-in proxy support. 2. Not disabling HTTP redirects. 3. Either not using an HTTPS origin server or for the proxy or target origin to redirect to a malicious origin. Users are advised to update to either version 1.26.19 or version 2.2.2. Users unable to upgrade may use the `Proxy-Authorization` header with urllib3's `ProxyManager`, disable HTTP redirects using `redirects=False` when sending requests, or not user the `Proxy-Authorization` header as mitigations.

CVSS metrics

8 scores · 8 sources · 1 version

EPSS trend

Probability

1.14%

Chance of exploitation in the next 30 days

Percentile

67%

Versus all other CVEs

30-day change

No change 0.00 pp

From 1.14% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

1 found
  • referenceUnverified

    Exploit Reference (vicarius.io)

    Maturity: unknown

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, administrative account, no user interaction (CVSS vector). Other conditions: not stated in public data.

Chainguard73 products
  • airflow< 2.9.2-r1
  • airflow-bitnami-compat< 2.9.2-r1
  • az< 2.61.0-r1
  • az-iamguarded-compat< 2.61.0-r1
  • barman< 3.10.1-r1
Wolfi61 products
  • airflow< 2.9.2-r1
  • airflow-bitnami-compat< 2.9.2-r1
  • az< 2.61.0-r1
  • az-iamguarded-compat< 2.61.0-r1
  • checkov< 3.0.34-r1
Redhat54 products
  • fence-agents< 0:4.10.0-62.el9_4.4 | < 0:4.2.1-65.el8_4.17 | < 0:4.2.1-112.el8_8.7 | < 0:4.2.1-89.el8_6.13 | < 0:4.10.0-20.el9_0.15 | < 0:4.10.0-43.el9_2.7
  • fence-agents-aliyun< 0:4.10.0-62.el9_4.4 | < 0:4.2.1-65.el8_4.17 | < 0:4.2.1-112.el8_8.7 | < 0:4.2.1-89.el8_6.13 | < 0:4.10.0-20.el9_0.15 | < 0:4.10.0-43.el9_2.7
  • fence-agents-aliyun-debuginfo< 0:4.2.1-65.el8_4.17 | < 0:4.2.1-112.el8_8.7 | < 0:4.2.1-89.el8_6.13
  • fence-agents-all< 0:4.10.0-62.el9_4.4 | < 0:4.2.1-65.el8_4.17 | < 0:4.2.1-112.el8_8.7 | < 0:4.2.1-89.el8_6.13 | < 0:4.10.0-20.el9_0.15 | < 0:4.10.0-43.el9_2.7
  • fence-agents-amt-ws< 0:4.10.0-62.el9_4.4 | < 0:4.2.1-65.el8_4.17 | < 0:4.2.1-112.el8_8.7 | < 0:4.2.1-89.el8_6.13 | < 0:4.10.0-20.el9_0.15 | < 0:4.10.0-43.el9_2.7
Opensuse4 products
  • python-urllib3_1&distro=openSUSE Leap 15.6< 1.26.18-150600.3.3.1
  • python-urllib3&distro=openSUSE Leap 15.5< 2.0.7-150400.7.18.1 | < 1.25.10-150300.4.12.1
  • python-urllib3&distro=openSUSE Leap 15.6< 2.0.7-150400.7.18.1
  • python-urllib3&distro=openSUSE Leap Micro 5.5< 1.25.10-150300.4.12.1
Debian2 products
  • python-urllib3< 1.26.12-1+deb12u1 | < 2.2.3-3
  • debian_linuxEOL11.0
Ubuntu2 products
  • python-pipAll versions (No fix recorded) | < 8.1.1-2ubuntu0.6+esm10 | < 9.0.1-2.3~ubuntu1.18.04.8+esm6 | < 20.0.2-5ubuntu1.11 | < 22.0.2+dfsg-1ubuntu0.5 | < 24.0+dfsg-1ubuntu1.1
  • python-urllib3< 1.13.1-2ubuntu0.16.04.4+esm2 | < 1.22-1ubuntu0.18.04.2+esm2 | < 1.25.8-2ubuntu0.4 | < 1.26.5-1~exp1ubuntu0.2 | < 2.0.7-1ubuntu0.1
Mageia1 product
  • python-urllib3< 1.26.20-1.mga9
Netapp1 product
PyPI1 product
  • urllib3< 1.26.19 | ≥ 2.0.0, < 2.2.2
Python1 product
  • urllib3< 1.26.19 | ≥ 2.0.0, < 2.2.2

10 vendors · 200 products · Showing 200 of 246

References

75 links
Show all 75 references