CVE-2024-39907: a sqlinjection in 1Panel
Vulnerability summary
CVE-2024-39907 is a critical (CVSS 9.8) vulnerability in 1panel-dev 1panel. EPSS estimates a 29.18% chance of exploitation in the next 30 days, higher than 98.1% of scored vulnerabilities. 1 public exploit is recorded.
Public exploit (GitHub, Date unknown)
Source freshness unavailable
How is this decided?Timeline
- 18-07-2024PublishedVulnerability first disclosed.
- 02-08-2024Last modifiedVulnerability information updated.
Description
1Panel is a web-based linux server management control panel. There are many sql injections in the project, and some of them are not well filtered, leading to arbitrary file writes, and ultimately leading to RCEs. These sql injections have been resolved in version 1.10.12-tls. Users are advised to upgrade. There are no known workarounds for these issues.
CVSS metrics
4 scores · 3 sources · 2 versions- OSV · GoEcosystem advisory · calculated9.8CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- NVDNIST9.8CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS trend
Probability
29.18%
Chance of exploitation in the next 30 days
Percentile
98%
Versus all other CVEs
30-day change
No change 0.00 pp
From 29.18% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
1 found1Panel
Maturity: poc
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
1panel-dev1 product
- 1panel≥ 1.10.9-tls, < 1.10.12-tls
Fit2cloud1 product
- 1panel≥ 1.10.9-lts, < 1.10.12-lts
Github.com/1Panel-dev1 product
- 1Panel< 1.10.12-tls | All versions (No fix recorded)
3 vendors · 3 products
References
4 links- github.com/1Panel-dev/1Panel/security/advisories/GHSA-5grx-v727-qmq6X Refsource CONFIRMWEBAdvisoryExploitThird Party Advisory
- github.com/1Panel-dev/1PanelPACKAGE