10

CVE-2024-41110: Moby authz zero length regression

Deferred
AliasesSUSE-SU-2024:2709-1SUSE-SU-2024:4204-1SUSE-SU-2024:4205-1
Published 24-07-2024Last modified 13-10-2024

Vulnerability summary

CVE-2024-41110 is a critical (CVSS 10.0) Partial String Comparison vulnerability in moby. EPSS estimates a 16.50% chance of exploitation in the next 30 days, higher than 96.9% of scored vulnerabilities.

Priority
Prioritisesevere

Severe, CVSS 10 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 16% (FIRST, 03-11-2026)

Source freshness unavailable

How is this decided?
CVSS score
10.0/10
010
Critical · v3.1 (CVE.org)
EPSS score
16.50%
0%100%
Medium · 0.00 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 18 · Related 162
OPENSUSE-SU-2025:14909-1SUSE-RU-2024:4391-1SUSE-SU-2024:3120-1SUSE-SU-2024:4319-1SUSE-SU-2024:4360-1SUSE-SU-2025:0226-1

Showing 100 of 162.

Timeline

  1. 24-07-2024
    PublishedVulnerability first disclosed.
  2. 13-10-2024
    Last modifiedVulnerability information updated.

Description

Moby is an open-source project created by Docker for software containerization. A security vulnerability has been detected in certain versions of Docker Engine, which could allow an attacker to bypass authorization plugins (AuthZ) under specific circumstances. The base likelihood of this being exploited is low. Using a specially-crafted API request, an Engine API client could make the daemon forward the request or response to an authorization plugin without the body. In certain circumstances, the authorization plugin may allow a request which it would have otherwise denied if the body had been forwarded to it. A security issue was discovered In 2018, where an attacker could bypass AuthZ plugins using a specially crafted API request. This could lead to unauthorized actions, including privilege escalation. Although this issue was fixed in Docker Engine v18.09.1 in January 2019, the fix was not carried forward to later major versions, resulting in a regression. Anyone who depends on authorization plugins that introspect the request and/or response body to make access control decisions is potentially impacted. Docker EE v19.03.x and all versions of Mirantis Container Runtime are not vulnerable. docker-ce v27.1.1 containes patches to fix the vulnerability. Patches have also been merged into the master, 19.03, 20.0, 23.0, 24.0, 25.0, 26.0, and 26.1 release branches. If one is unable to upgrade immediately, avoid using AuthZ plugins and/or restrict access to the Docker API to trusted parties, following the principle of least privilege.

CVSS metrics

9 scores · 8 sources · 2 versions

EPSS trend

Probability

16.50%

Chance of exploitation in the next 30 days

Percentile

97%

Versus all other CVEs

30-day change

No change 0.00 pp

From 16.50% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, low-privilege account, no user interaction (CVSS vector). Other conditions: not stated in public data.

Chainguard199 products
  • aactl< 0.4.12-r16
  • apko< 0.17.0-r1
  • argo-workflows< 3.6.5-r2
  • argo-workflows-fips< 3.6.5-r2
  • bom< 0.6.0-r8
Alpine1 product
  • docker< 26.1.5-r0 | < 27.1.1-r0

2 vendors · 200 products · Showing 200 of 357

References

36 links
Show all 36 references