CVE-2024-43792: Halo's editor has a stored Cross-Site Scripting vulnerability
Vulnerability summary
CVE-2024-43792 is a medium (CVSS 6.3) vulnerability in halo-dev halo. EPSS estimates a 0.35% chance of exploitation in the next 30 days, higher than 28.7% of scored vulnerabilities. 1 public exploit is recorded.
Not severe (CVSS 6.3, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Timeline
- 02-09-2024PublishedVulnerability first disclosed.
- 03-09-2024Last modifiedVulnerability information updated.
Description
Halo is an open source website building tool. A security vulnerability has been identified in versions prior to 2.17.0 of the Halo project. This vulnerability allows an attacker to execute malicious scripts in the user's browser through specific HTML and JavaScript code, potentially leading to a Cross-Site Scripting (XSS) attack. Users are advised to upgrade to version 2.17.0+. There are no known workarounds for this vulnerability.
CVSS metrics
2 scores · 2 sources · 1 version- NVDNIST6.1MediumCVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NDiffers
EPSS trend
Probability
0.35%
Chance of exploitation in the next 30 days
Percentile
29%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.35% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
1 foundHalo
Maturity: poc
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, no authentication, user interaction (CVSS vector). Other conditions: not stated in public data.
Halo1 product
- halo< 2.17.0
Halo-dev1 product
- halo< 2.17.0
2 vendors · 2 products
References
1 links- github.com/halo-dev/halo/security/advisories/GHSA-x3rj-3x75-vw4gX Refsource CONFIRMExploitVendor Advisory