CVE-2024-45606: Improper authorization on muting of alert rules in sentry
Vulnerability summary
CVE-2024-45606 is a high (CVSS 7.1) vulnerability in getsentry sentry. EPSS estimates a 0.36% chance of exploitation in the next 30 days, higher than 29.5% of scored vulnerabilities.
Not severe (CVSS 7.1, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Timeline
- 17-09-2024PublishedVulnerability first disclosed.
- 18-09-2024Last modifiedVulnerability information updated.
Description
Sentry is a developer-first error tracking and performance monitoring platform. An authenticated user can mute alert rules from arbitrary organizations and projects with a know rule ID. The user does not need to be a member of the organization or have permissions on the project. In our review, we have identified no instances where alerts have been muted by unauthorized parties. A patch was issued to ensure authorization checks are properly scoped on requests to mute alert rules. Authenticated users who do not have the necessary permissions are no longer able to mute alerts. Sentry SaaS users do not need to take any action. Self-Hosted Sentry users should upgrade to version **24.9.0** or higher. The rule mute feature was generally available as of 23.6.0 but users with early access may have had the feature as of 23.4.0. Affected users are advised to upgrade to version 24.9.0. There are no known workarounds for this vulnerability.
CVSS metrics
4 scores · 3 sources · 2 versions- OSV · PypiEcosystem advisory · calculated7.1HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N
- NVDNIST4.3MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:NDiffers
EPSS trend
Probability
0.36%
Chance of exploitation in the next 30 days
Percentile
30%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.36% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, low-privilege account, no user interaction (CVSS vector). Other conditions: not stated in public data.
Getsentry1 product
- sentry≥ 23.4.0, < 24.9.0
PyPI1 product
- sentry≥ 23.4.0, < 24.9.0
Sentry1 product
- sentry≥ 23.4.0, < 24.9.0
3 vendors · 3 products
References
8 links- github.com/getsentry/sentry/security/advisories/GHSA-v345-w9f2-mpm5X Refsource CONFIRMWEBVendor Advisory
- github.com/getsentry/sentryPACKAGE
- pypi.org/project/sentryPACKAGE