8.8

CVE-2024-56201: Jinja has a sandbox breakout through malicious filenames

Analyzed
AliasesALPINE-CVE-2024-56201GHSA-gmj6-6f8f-6699PYSEC-2026-1472
Published 23-12-2024Last modified 18-02-2025

Vulnerability summary

CVE-2024-56201 is a high (CVSS 8.8) vulnerability in pallets jinja. EPSS estimates a 0.31% chance of exploitation in the next 30 days, higher than 23.5% of scored vulnerabilities.

Priority
Routine

Not severe (CVSS 5.4, local access); no exploitation reported by the 5 checked sources

Source freshness unavailable

How is this decided?
CVSS score
8.8/10
010
High · v3.1 (NVD)
EPSS score
0.31%
0%100%
Low · 0.00 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 20 · Related 24

Timeline

  1. 23-12-2024
    PublishedVulnerability first disclosed.
  2. 18-02-2025
    Last modifiedVulnerability information updated.

Description

Jinja is an extensible templating engine. In versions on the 3.x branch prior to 3.1.5, a bug in the Jinja compiler allows an attacker that controls both the content and filename of a template to execute arbitrary Python code, regardless of if Jinja's sandbox is used. To exploit the vulnerability, an attacker needs to control both the filename and the contents of a template. Whether that is the case depends on the type of application using Jinja. This vulnerability impacts users of applications which execute untrusted templates where the template author can also choose the template filename. This vulnerability is fixed in 3.1.5.

CVSS metrics

11 scores · 8 sources · 2 versions

EPSS trend

Probability

0.31%

Chance of exploitation in the next 30 days

Percentile

24%

Versus all other CVEs

30-day change

No change 0.00 pp

From 0.31% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: local access, low-privilege account, user interaction (CVSS vector). Other conditions: not stated in public data.

Chainguard34 products
  • airflow< 2.10.4-r2
  • airflow-bitnami-compat< 2.10.4-r2
  • ansible-operator< 1.37.1-r0
  • ansible-operator-compat< 1.37.1-r0
  • apache-beam-python-3.11-sdk< 2.61.0-r1
Wolfi28 products
  • airflow< 2.10.4-r2
  • airflow-bitnami-compat< 2.10.4-r2
  • checkov< 3.2.432-r0
  • dask-gateway< 2024.1.0-r13
  • emissary< 3.9.1-r8
Alpine1 product
  • py3-jinja2< 3.1.5-r0
Debian1 product
  • jinja2< 3.1.2-1+deb12u2 | < 3.1.5-1
Pallets1 product
Palletsprojects1 product
PyPI1 product
  • jinja2≥ 3.0.0, < 3.1.5
Ubuntu1 product
  • jinja2< 2.7.2-2ubuntu0.1~esm6 | < 2.8-1ubuntu0.1+esm5 | < 2.10-1ubuntu0.18.04.1+esm3 | < 2.10.1-2ubuntu0.4 | < 3.0.3-1ubuntu0.3 | < 3.1.2-1ubuntu1.2

8 vendors · 68 products

References

15 links
Show all 15 references