9.8

CVE-2025-21613: go-git has an Argument Injection via the URL field

Analyzed
AliasesSUSE-SU-2025:0191-1SUSE-SU-2025:0277-1UBUNTU-CVE-2025-21613
Published 06-01-2025Last modified 06-01-2025

Vulnerability summary

CVE-2025-21613 is a critical (CVSS 9.8) vulnerability in go-git_project go-git. EPSS estimates a 1.28% chance of exploitation in the next 30 days, higher than 70% of scored vulnerabilities.

Priority
Prioritisesevere

Severe, CVSS 9.2 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 1% (FIRST, 03-11-2026)

Source freshness unavailable

How is this decided?
CVSS score
9.8/10
010
Critical · v3.1 (CVE.org)
EPSS score
1.28%
0%100%
Low · -0.01 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 17 · Related 81
OPENSUSE-SU-2025:0056-1OPENSUSE-SU-2025:14624-1OPENSUSE-SU-2025:14713-1OPENSUSE-SU-2025:14902-1OPENSUSE-SU-2025:15487-1OPENSUSE-SU-2025:20117-1

Timeline

  1. 06-01-2025
    PublishedVulnerability first disclosed.
  2. 06-01-2025
    Last modifiedVulnerability information updated.

Description

go-git is a highly extensible git implementation library written in pure Go. An argument injection vulnerability was discovered in go-git versions prior to v5.13. Successful exploitation of this vulnerability could allow an attacker to set arbitrary values to git-upload-pack flags. This only happens when the file transport protocol is being used, as that is the only protocol that shells out to git binaries. This vulnerability is fixed in 5.13.0.

CVSS metrics

11 scores · 7 sources · 2 versions

EPSS trend

Probability

1.28%

Chance of exploitation in the next 30 days

Percentile

70%

Versus all other CVEs

30-day change

Decrease -0.01 pp

From 1.29% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.

Chainguard161 products
  • amazon-ssm-agent< 3.3.1957.0-r5
  • amazon-ssm-agent-ecs-exec< 3.3.1957.0-r5
  • apko< 0.22.5-r0
  • argo-cd-2.11< 2.11.12-r3
  • argo-cd-2.13< 2.13.3-r1
Wolfi39 products
  • apko< 0.22.5-r0
  • argo-events< 1.9.3-r3
  • argo-workflows< 3.6.2-r4
  • argocd-image-updater< 0.15.2-r1
  • argocd-image-updater-compat< 0.15.2-r1

2 vendors · 200 products · Showing 200 of 249

References

15 links
Show all 15 references