CVE-2025-21614: go-git clients vulnerable to DoS via maliciously crafted Git server replies
Vulnerability summary
CVE-2025-21614 is a high (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in go-git_project go-git. EPSS estimates a 0.72% chance of exploitation in the next 30 days, higher than 53.8% of scored vulnerabilities.
Severe, CVSS 7.5 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 1% (FIRST, 03-11-2026)
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 10 · Related 74Timeline
- 06-01-2025PublishedVulnerability first disclosed.
- 26-08-2025Last modifiedVulnerability information updated.
Description
go-git is a highly extensible git implementation library written in pure Go. A denial of service (DoS) vulnerability was discovered in go-git versions prior to v5.13. This vulnerability allows an attacker to perform denial of service attacks by providing specially crafted responses from a Git server which triggers resource exhaustion in go-git clients. Users running versions of go-git from v4 and above are recommended to upgrade to v5.13 in order to mitigate this vulnerability.
CVSS metrics
7 scores · 7 sources · 1 version- OSV · UbuntuEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- OSV · DebianEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- OSV · WolfiEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- OSV · GoEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- OSV · ChainguardEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- NVDNIST7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS trend
Probability
0.72%
Chance of exploitation in the next 30 days
Percentile
54%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.72% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Chainguard161 products
- amazon-ssm-agent< 3.3.1957.0-r5
- amazon-ssm-agent-ecs-exec< 3.3.1957.0-r5
- apko< 0.22.5-r0
- argo-cd-2.11< 2.11.12-r3
- argo-cd-2.13< 2.13.3-r1
Wolfi39 products
- apko< 0.22.5-r0
- argo-events< 1.9.3-r3
- argo-workflows< 3.6.2-r4
- argocd-image-updater< 0.15.2-r1
- argocd-image-updater-compat< 0.15.2-r1
2 vendors · 200 products · Showing 200 of 240
References
8 links- github.com/go-git/go-git/security/advisories/GHSA-r9px-m959-cxf4X Refsource CONFIRMREPORTAdvisoryWEBVendor Advisory
- github.com/go-git/go-gitPACKAGE