6.8

CVE-2025-22150: Undici Uses Insufficiently Random Values

Deferred
AliasesALPINE-CVE-2025-22150UBUNTU-CVE-2025-22150DEBIAN-CVE-2025-22150
Published 21-01-2025Last modified 12-02-2025

Vulnerability summary

CVE-2025-22150 is a medium (CVSS 6.8) Use of Insufficiently Random Values vulnerability in nodejs undici. EPSS estimates a 0.76% chance of exploitation in the next 30 days, higher than 55.4% of scored vulnerabilities.

Priority
Routine

Not severe (CVSS 6.8, network access); no exploitation reported by the 5 checked sources

Source freshness unavailable

How is this decided?
CVSS score
6.8/10
010
Medium · v3.1 (CVE.org)
EPSS score
0.76%
0%100%
Low · 0.00 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 18 · Related 13

Timeline

  1. 21-01-2025
    PublishedVulnerability first disclosed.
  2. 12-02-2025
    Last modifiedVulnerability information updated.

Description

Undici is an HTTP/1.1 client. Starting in version 4.5.0 and prior to versions 5.28.5, 6.21.1, and 7.2.3, undici uses `Math.random()` to choose the boundary for a multipart/form-data request. It is known that the output of `Math.random()` can be predicted if several of its generated values are known. If there is a mechanism in an app that sends multipart requests to an attacker-controlled website, they can use this to leak the necessary values. Therefore, an attacker can tamper with the requests going to the backend APIs if certain conditions are met. This is fixed in versions 5.28.5, 6.21.1, and 7.2.3. As a workaround, do not issue multipart requests to attacker controlled servers.

CVSS metrics

8 scores · 8 sources · 1 version

EPSS trend

Probability

0.76%

Chance of exploitation in the next 30 days

Percentile

55%

Versus all other CVEs

30-day change

No change 0.00 pp

From 0.76% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, no authentication, user interaction (CVSS vector). Other conditions: not stated in public data.

Alpine1 product
  • nodejs< 22.13.1-r0
Chainguard1 product
  • jitsucom-jitsu< 2.8.6-r1
Debian1 product
  • node-undiciAll versions (No fix recorded) | < 7.3.0+dfsg1+~cs24.12.11-1
Nodejs1 product
  • undici≥ 4.5.0, < 5.28.5 | ≥ 6.0.0, < 6.21.1 | ≥ 7.0.0, < 7.2.3
Npm1 product
  • undici≥ 4.5.0, < 5.28.5 | ≥ 6.0.0, < 6.21.1 | ≥ 7.0.0, < 7.2.3
Ubuntu1 product
  • node-undiciAll versions (No fix recorded)
Wolfi1 product
  • jitsucom-jitsu< 2.8.6-r1

7 vendors · 7 products

References

14 links
Show all 14 references