9.8

CVE-2025-27138: DataEase has an improper authentication vulnerability

Analyzed
Published 13-03-2025Last modified 13-03-2025

Vulnerability summary

CVE-2025-27138 is a critical (CVSS 9.8) Improper Authentication vulnerability in dataease. EPSS estimates a 0.59% chance of exploitation in the next 30 days, higher than 48.1% of scored vulnerabilities. 1 public exploit is recorded.

Priority
Prioritisepublic exploit

Public exploit (GitHub, Date unknown)

Source freshness unavailable

How is this decided?
CVSS score
9.8/10
010
Critical · v3.1 (NVD)
EPSS score
0.59%
0%100%
Low · +0.01 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits1github

Timeline

  1. 13-03-2025
    PublishedVulnerability first disclosed.
  2. 13-03-2025
    Last modifiedVulnerability information updated.

Description

DataEase is an open source business intelligence and data visualization tool. Prior to version 2.10.6, there is a flaw in the authentication in the io.dataease.auth.filter.TokenFilter class, which may cause the risk of unauthorized access. The vulnerability has been fixed in v2.10.6. No known workarounds are available.

CVSS metrics

3 scores · 2 sources · 2 versions

EPSS trend

Probability

0.59%

Chance of exploitation in the next 30 days

Percentile

48%

Versus all other CVEs

30-day change

Increase +0.01 pp

From 0.58% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

1 found
  • githubUnverified

    Dataease

    Maturity: poc

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.

Dataease1 product

1 vendor · 1 product

References

1 links