CVE-2025-3888: Jupiterx Core <= 4.8.12 - Authenticated (Contributor+) Stored Cross-Site Scripting via Inline SVG
Vulnerability summary
CVE-2025-3888 is a medium (CVSS 6.4) Cross-site Scripting vulnerability in artbees jupiter x core. EPSS estimates a 0.34% chance of exploitation in the next 30 days, higher than 26.8% of scored vulnerabilities. Fixed in 4.9.1.
Timeline
- 17-05-2025PublishedVulnerability first disclosed.
- 08-04-2026Last modifiedVulnerability information updated.
Description
The Jupiter X Core plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG File inclusion in all versions up to, and including, 4.8.12 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses the page with the included SVG file.
CVSS metrics
3 scores · 3 sources · 1 version- NVDNIST5.4MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:NDiffers
- wordfenceSource6.4MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
EPSS trend
Probability
0.34%
Chance of exploitation in the next 30 days
Percentile
27%
Versus all other CVEs
30-day change
Increase +0.01 pp
From 0.32% on 27-09-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Artbees1 product
- jupiter x core≤ 4.8.12
Wordpress1 product
- jupiterx-core≤ 4.8.12 (fixed in 4.9.1)
2 vendors · 2 products