CVE-2025-46701: Apache Tomcat: Security constraint bypass for CGI scripts
Vulnerability summary
CVE-2025-46701 is a high (CVSS 7.3) Improper Handling of Case Sensitivity vulnerability in apache software foundation apache tomcat. EPSS estimates a 3.14% chance of exploitation in the next 30 days, higher than 87.9% of scored vulnerabilities.
Severe, CVSS 7.3 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 3% (FIRST, 03-11-2026)
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 21 · Related 10Timeline
- 29-05-2025PublishedVulnerability first disclosed.
- 03-11-2025Last modifiedVulnerability information updated.
Description
Improper Handling of Case Sensitivity vulnerability in Apache Tomcat's GCI servlet allows security constraint bypass of security constraints that apply to the pathInfo component of a URI mapped to the CGI servlet. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.6, from 10.1.0-M1 through 10.1.40, from 9.0.0.M1 through 9.0.104. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.7, 10.1.41 or 9.0.105, which fixes the issue.
CVSS metrics
7 scores · 7 sources · 2 versions- OSV · UbuntuEcosystem advisory · calculated7.3HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- OSV · DebianEcosystem advisory · calculated7.3HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- OSV · WolfiEcosystem advisory · calculated7.3HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- OSV · ChainguardEcosystem advisory · calculated7.3HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- NVDNIST7.3HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
EPSS trend
Probability
3.14%
Chance of exploitation in the next 30 days
Percentile
88%
Versus all other CVEs
30-day change
Increase +0.22 pp
From 2.93% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Ubuntu6 products
- tomcat10< 10.1.16-1ubuntu0.1~esm3
- tomcat11All versions (No fix recorded)
- tomcat6All versions (No fix recorded)
- tomcat7All versions (No fix recorded)
- tomcat8All versions (No fix recorded)
Chainguard5 products
- thingsboard< 4.0.1-r4
- thingsboard-tb-js-executor< 4.0.1-r4
- thingsboard-tb-mqtt-transport< 4.0.1-r4
- thingsboard-tb-node< 4.0.1-r4
- thingsboard-tb-web-ui< 4.0.1-r4
Wolfi5 products
- thingsboard< 4.0.1-r4
- thingsboard-tb-js-executor< 4.0.1-r4
- thingsboard-tb-mqtt-transport< 4.0.1-r4
- thingsboard-tb-node< 4.0.1-r4
- thingsboard-tb-web-ui< 4.0.1-r4
Debian3 products
- tomcat10< 10.1.52-1~deb12u1 | < 10.1.52-1~deb13u1 | < 10.1.46-1
- tomcat11< 11.0.15-1~deb13u1 | < 11.0.11-1
- tomcat9< 9.0.70-2
Apache1 product
- tomcat≥ 9.0.0, < 9.0.105 | ≥ 10.1.0, < 10.1.41 | ≥ 11.0.0, < 11.0.7
Apache software foundation1 product
- apache tomcat≥ 11.0.0-M1, ≤ 11.0.6 | ≥ 10.1.0-M1, ≤ 10.1.40 | ≥ 9.0.0.M1, ≤ 9.0.104 | ≥ 8.5.0, ≤ 8.5.100
Mageia1 product
- tomcat< 9.0.105-1.mga9
Org.apache.tomcat1 product
- tomcat-catalina≥ 9.0.0.M1, < 9.0.105 | ≥ 10.1.0-M1, < 10.1.41 | ≥ 11.0.0-M1, < 11.0.7 | ≥ 8.5.0, ≤ 8.5.100
Org.apache.tomcat.embed1 product
- tomcat-embed-core≥ 9.0.0.M1, < 9.0.105 | ≥ 10.1.0-M1, < 10.1.41 | ≥ 11.0.0-M1, < 11.0.7 | ≥ 8.5.0, ≤ 8.5.100
9 vendors · 24 products
References
22 links- lists.apache.org/thread/xhqqk9w5q45srcdqhogdk04lhdscv30jVendor AdvisoryREPORTAdvisoryWEBMailing List
Show all 22 references
- github.com/apache/tomcatPACKAGE