CVE-2025-47943: Gogs stored XSS in PDF renderer
Vulnerability summary
CVE-2025-47943 is a medium (CVSS 6.3) vulnerability in gogs. EPSS estimates a 0.40% chance of exploitation in the next 30 days, higher than 33.7% of scored vulnerabilities.
Not severe (CVSS 6.3, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 1 · Related 1Timeline
- 24-06-2025PublishedVulnerability first disclosed.
- 30-07-2025Last modifiedVulnerability information updated.
Description
Gogs is an open source self-hosted Git service. In application version 0.14.0+dev and prior, there is a stored cross-site scripting (XSS) vulnerability present in Gogs, which allows client-side Javascript code execution. The vulnerability is caused by the usage of a vulnerable and outdated component: pdfjs-1.4.20 under public/plugins/. This issue has been fixed for gogs.io/gogs in version 0.13.3.
CVSS metrics
3 scores · 3 sources · 1 version- OSV · GoEcosystem advisory · calculated6.3MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N
- NVDNIST6.3MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:L/A:N
EPSS trend
Probability
0.40%
Chance of exploitation in the next 30 days
Percentile
34%
Versus all other CVEs
30-day change
Increase +0.01 pp
From 0.39% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, low-privilege account, user interaction (CVSS vector). Other conditions: not stated in public data.
Github.com/gogs1 product
- gogs< 0.13.3-0.20250608224432-110117b2e5e5
Gogs1 product
- gogs≤ 0.14.0+dev
Gogs.io1 product
- gogs< 0.13.3-0.20250608224432-110117b2e5e5
3 vendors · 3 products
References
6 links- github.com/gogs/gogsPACKAGE