CVE-2025-59146: New API has Authenticated Server-Side Request Forgery (SSRF) issue
Vulnerability summary
CVE-2025-59146 is a high (CVSS 8.5) Server-Side Request Forgery vulnerability in quantumnous new-api. EPSS estimates a 0.24% chance of exploitation in the next 30 days, higher than 15.7% of scored vulnerabilities.
Not severe (CVSS 8.5, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Timeline
- 09-10-2025PublishedVulnerability first disclosed.
- 09-10-2025Last modifiedVulnerability information updated.
Description
New API is a large language mode (LLM) gateway and artificial intelligence (AI) asset management system. An authenticated Server-Side Request Forgery (SSRF) vulnerability exists in versions prior to 0.9.0.5. A feature within the application allows authenticated users to submit a URL for the server to process its content. The application fails to properly validate this user-supplied URL before making a server-side request. This vulnerability is not limited to image URLs and can be triggered with any link provided to the vulnerable endpoint. Since user registration is often enabled by default, any registered user can exploit this. By crafting a malicious URL, an attacker can coerce the server to send requests to arbitrary internal or external services. The vulnerability has been patched in version 0.9.0.5. The patch introduces a comprehensive, user-configurable SSRF protection module, which is enabled by default to protect server security. This new feature provides administrators with granular control over outbound requests made by the server. For users who cannot upgrade immediately, some temporary mitigation options are available. Enable new-api image processing worker (new-api-worker) and/or configure egress firewall rules.
CVSS metrics
2 scores · 2 sources · 1 version- NVDNIST8.5HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N
EPSS trend
Probability
0.24%
Chance of exploitation in the next 30 days
Percentile
16%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.24% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, low-privilege account, no user interaction (CVSS vector). Other conditions: not stated in public data.
Quantumnous1 product
- new-api< 0.9.0.5
1 vendor · 1 product
References
2 links- github.com/QuantumNous/new-api/security/advisories/GHSA-xxv6-m6fx-vfhhX Refsource CONFIRM