CVE-2025-59419: Netty netty-codec-smtp SMTP Command Injection Vulnerability Allowing Email Forgery
Vulnerability summary
CVE-2025-59419 is a medium (CVSS 5.5) vulnerability in netty. EPSS estimates a 1.55% chance of exploitation in the next 30 days, higher than 75.1% of scored vulnerabilities.
Not severe (CVSS 5.5, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 2 · Related 3Timeline
- 15-10-2025PublishedVulnerability first disclosed.
- 17-10-2025Last modifiedVulnerability information updated.
Description
Netty is an asynchronous, event-driven network application framework. In versions prior to 4.1.128.Final and 4.2.7.Final, the SMTP codec in Netty contains an SMTP command injection vulnerability due to insufficient input validation for Carriage Return (\r) and Line Feed (\n) characters in user-supplied parameters. The vulnerability exists in io.netty.handler.codec.smtp.DefaultSmtpRequest, where parameters are directly concatenated into the SMTP command string without sanitization. When methods such as SmtpRequests.rcpt(recipient) are called with a malicious string containing CRLF sequences, attackers can inject arbitrary SMTP commands. Because the injected commands are sent from the server's trusted IP address, resulting emails will likely pass SPF and DKIM authentication checks, making them appear legitimate. This allows remote attackers who can control SMTP command parameters (such as email recipients) to forge arbitrary emails from the trusted server, potentially impersonating executives and forging high-stakes corporate communications. This issue has been patched in versions 4.1.129.Final and 4.2.8.Final. No known workarounds exist.
CVSS metrics
7 scores · 7 sources · 1 version- OSV · UbuntuEcosystem advisory · calculated6.9MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:PDiffers
- OSV · DebianEcosystem advisory · calculated6.9MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:XDiffers
- OSV · WolfiEcosystem advisory · calculated6.9MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:PDiffers
- OSV · ChainguardEcosystem advisory · calculated6.9MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:PDiffers
- OSV · MavenEcosystem advisory · calculated8.7HighCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:PDiffers
- NVDNIST5.5MediumCVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
EPSS trend
Probability
1.55%
Chance of exploitation in the next 30 days
Percentile
75%
Versus all other CVEs
30-day change
No change 0.00 pp
From 1.55% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Chainguard88 products
- apache-hop< 2.15.0-r13
- apache-hop-fips< 2.15.0-r15
- celeborn-0.5< 0.5.4-r8
- celeborn-0.5-compat< 0.5.4-r8
- celeborn-0.6< 0.6.3-r7
Wolfi68 products
- celeborn-0.6< 0.6.3-r7
- management-api-for-apache-cassandra-5.0< 0.1.108-r2
- management-api-for-apache-cassandra-5.0-compat< 0.1.108-r2
- tez< 0.10.5-r6
- thingsboard< 4.2.1-r1
Suse4 products
- netty-tcnative&distro=SUSE Linux Enterprise Module for Development Tools 15 SP6< 2.0.74-150200.3.33.1
- netty-tcnative&distro=SUSE Linux Enterprise Module for Development Tools 15 SP7< 2.0.74-150200.3.33.1
- netty&distro=SUSE Linux Enterprise Module for Package Hub 15 SP6< 4.1.128-150200.4.37.1
- netty&distro=SUSE Linux Enterprise Module for Package Hub 15 SP7< 4.1.128-150200.4.37.1
Opensuse3 products
- netty-tcnative&distro=openSUSE Leap 15.6< 2.0.74-150200.3.33.1
- netty&distro=openSUSE Leap 15.6< 4.1.128-150200.4.37.1
- netty&distro=openSUSE Tumbleweed< 4.1.128-1.1
Debian1 product
- netty< 1:4.1.48-7+deb12u2 | < 1:4.1.48-10+deb13u1 | < 1:4.1.48-11
Io.netty1 product
- netty-codec-smtp≥ 4.2.0.Alpha1, < 4.2.7.Final | < 4.1.128.Final
Netty1 product
- netty< 4.2.7.Final | ≥ 4.2.0.Alpha1, < 4.1.128.Final
Ubuntu1 product
- netty< 1:4.1.7-4ubuntu0.1+esm4 | < 1:4.1.45-1ubuntu0.1~esm3 | < 1:4.1.48-4+deb11u2ubuntu0.1~esm2 | < 1:4.1.48-9ubuntu0.1~esm2 | < 1:4.1.48-10ubuntu0.25.10.1 | All versions (No fix recorded)
8 vendors · 167 products
References
15 linksShow all 15 references
- github.com/netty/nettyPACKAGE