CVE-2025-62718: Axios has a NO_PROXY Hostname Normalization Bypass that Leads to SSRF
Vulnerability summary
CVE-2025-62718 is a critical (CVSS 9.9) Unintended Proxy or Intermediary vulnerability in axios. EPSS estimates a 1.19% chance of exploitation in the next 30 days, higher than 67.8% of scored vulnerabilities. 1 public exploit is recorded.
Not severe (CVSS 6.3, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 1 · Related 2Timeline
- 09-04-2026PublishedVulnerability first disclosed.
- 10-09-2026Last modifiedVulnerability information updated.
Description
Axios is a promise based HTTP client for the browser and Node.js. Prior to 1.15.0 and 0.31.0, Axios does not correctly handle hostname normalization when checking NO_PROXY rules. Requests to loopback addresses like localhost. (with a trailing dot) or [::1] (IPv6 literal) skip NO_PROXY matching and go through the configured proxy. This goes against what developers expect and lets attackers force requests through a proxy, even if NO_PROXY is set up to protect loopback or internal services. This issue leads to the possibility of proxy bypass and SSRF vulnerabilities allowing attackers to reach sensitive loopback or internal services despite the configured protections. This vulnerability is fixed in 1.15.0 and 0.31.0.
CVSS metrics
11 scores · 7 sources · 2 versions- OSV · UbuntuEcosystem advisory · calculated6.3MediumCVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N
- OSV · WolfiEcosystem advisory · calculated6.3MediumCVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N
- OSV · NpmEcosystem advisory · calculated6.3MediumCVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N
- OSV · ChainguardEcosystem advisory · calculated6.3MediumCVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N
- NVDNIST6.3MediumCVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- CVE.orgCNA7.0HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:LDiffers
- OSV · UbuntuEcosystem advisory · calculated9.9CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:L
- OSV · DebianEcosystem advisory · calculated9.9CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:L
- OSV · NpmEcosystem advisory · calculated4.8MediumCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:NDiffers
EPSS trend
Probability
1.19%
Chance of exploitation in the next 30 days
Percentile
68%
Versus all other CVEs
30-day change
No change 0.00 pp
From 1.19% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
1 foundAxios
Maturity: poc
Weaknesses
CWE · root cause- CWE-441Unintended Proxy or IntermediaryThe product receives a request, message, or directive from an upstream component, but the product does not sufficiently preserve the original source of the request before forwarding the request to an external actor that is outside of the product's control sphere.
- CWE-918Server-Side Request ForgeryThe web server receives a URL or similar request from an upstream component and retrieves the contents of this URL, but it does not sufficiently ensure that the request is being sent to the expected destination.
- CWE-1289Improper Validation of Unsafe Equivalence in InputThe product receives an input value that is used as a resource identifier or other type of reference, but it does not validate or incorrectly validates that the input is equivalent to a potentially-unsafe value.
Affected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Chainguard82 products
- airflow-2All versions (No fix recorded)
- airflow-core-2All versions (No fix recorded)
- arangodb-3.11< 3.11.14.5-r14
- awx< 24.6.1-r42
- gitlab-rails-ce-18.1All versions (No fix recorded)
Wolfi20 products
- jitsucom-jitsu-console< 2.11.0-r21
- katib-earlystopping< 0.19.0-r31
- katib-suggestion-goptuna-compatAll versions (No fix recorded)
- katib-suggestion-hyperband< 0.19.0-r31
- katib-suggestion-hyperopt< 0.19.0-r40 | < 0.19.0-r31
Axios1 product
- axios< 0.31.0 | ≥ 1.0.0, < 1.15.0
Debian1 product
- node-axiosAll versions (No fix recorded) | < 1.15.0-1
Npm1 product
- axios≥ 1.0.0, < 1.15.0 | < 0.31.0
Ubuntu1 product
- node-axios< 0.19.0+dfsg-2ubuntu0.1~esm1 | < 0.26.0+dfsg-1ubuntu0.1~esm1 | < 1.6.8+dfsg-2ubuntu0.1~esm1 | All versions (No fix recorded) | < 1.13.2+dfsg-1ubuntu0.1~esm1
6 vendors · 106 products
References
51 links- github.com/axios/axios/security/advisories/GHSA-3p68-rc4w-qgx5X Refsource CONFIRMREPORTAdvisoryWEBExploitMitigationVendor Advisory
- github.com/axios/axios/commit/fb3befb6daac6cad26b2e54094d0f2d9e47f24dfX Refsource MISCREPORTFIXWEBPatch
Show all 51 references
- github.com/axios/axiosPACKAGE