CVE-2025-65637: turbopuffer logrus Uncontrolled Resource Consumption
Vulnerability summary
CVE-2025-65637 is a high (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in turbopuffer logrus. EPSS estimates a 0.63% chance of exploitation in the next 30 days, higher than 50.2% of scored vulnerabilities. 3 public exploits are recorded.
Public exploit (GitHub, Date unknown)
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 15 · Related 16Timeline
- 04-12-2025PublishedVulnerability first disclosed.
- 05-12-2025Last modifiedVulnerability information updated.
Description
A denial-of-service vulnerability exists in github.com/sirupsen/logrus when using Entry.Writer() to log a single-line payload larger than 64KB without newline characters. Due to limitations in the internal bufio.Scanner, the read fails with "token too long" and the writer pipe is closed, leaving Writer() unusable and causing application unavailability (DoS). This affects versions < 1.8.3, 1.9.0, and 1.9.2. The issue is fixed in 1.8.3, 1.9.1, and 1.9.3+, where the input is chunked and the writer continues to function even if an error is logged.
CVSS metrics
8 scores · 8 sources · 2 versions- OSV · Red hatEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- OSV · UbuntuEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- OSV · DebianEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- OSV · WolfiEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- OSV · ChainguardEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- NVDNIST7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS trend
Probability
0.63%
Chance of exploitation in the next 30 days
Percentile
50%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.63% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
3 foundLogrus Dos Poc
Maturity: poc
Logrus
Maturity: poc
Exploit Reference (security.snyk.io)
Maturity: unknown
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Chainguard77 products
- aws-flb-cloudwatch< 1.9.4-r22
- aws-flb-cloudwatch-compat< 1.9.4-r22
- aws-flb-cloudwatch-compat-fips< 1.9.4-r16
- aws-flb-cloudwatch-fips< 1.9.4-r16
- aws-flb-firehose< 1.7.2-r22
Redhat36 products
- microshift< 0:4.17.49-202602161401.p0.g708a69a.assembly.4.17.49.el9 | < 0:4.16.58-202603160404.p0.gb9661ec.assembly.4.16.58.el9
- microshift-greenboot< 0:4.17.49-202602161401.p0.g708a69a.assembly.4.17.49.el9 | < 0:4.16.58-202603160404.p0.gb9661ec.assembly.4.16.58.el9
- microshift-low-latency< 0:4.17.49-202602161401.p0.g708a69a.assembly.4.17.49.el9
- microshift-multus< 0:4.17.49-202602161401.p0.g708a69a.assembly.4.17.49.el9 | < 0:4.16.58-202603160404.p0.gb9661ec.assembly.4.16.58.el9
- microshift-multus-release-info< 0:4.17.49-202602161401.p0.g708a69a.assembly.4.17.49.el9 | < 0:4.16.58-202603160404.p0.gb9661ec.assembly.4.16.58.el9
Wolfi27 products
- aws-flb-cloudwatch< 1.9.4-r22
- aws-flb-cloudwatch-compat< 1.9.4-r22
- aws-flb-firehose< 1.7.2-r22
- aws-flb-firehose-compat< 1.7.2-r22
- aws-flb-kinesis< 1.10.3-r3
Debian1 product
- golang-logrusAll versions (No fix recorded) | < 1.9.3-1
Github.com/sirupsen1 product
- logrus< 1.8.3 | ≥ 1.9.0, < 1.9.1 | ≥ 1.9.2, < 1.9.3
Turbopuffer1 product
- logrus< 1.8.3 | 1.9.0 | 1.9.2
Ubuntu1 product
- golang-logrusAll versions (No fix recorded)
7 vendors · 144 products
References
54 links- security.snyk.io/vuln/SNYK-GOLANG-GITHUBCOMSIRUPSENLOGRUS-5564391ARTICLEREPORTWEBExploitThird Party Advisory
Show all 54 references
- github.com/sirupsen/logrusPACKAGE