5.1

CVE-2025-65944: Sentry-Javascript deals with leaked sensitive headers when `sendDefaultPii` is set to `true`

Deferred
AliasesGHSA-6465-jgvq-jhgp
Published 25-11-2025Last modified 25-11-2025

Vulnerability summary

CVE-2025-65944 is a medium (CVSS 5.1) vulnerability in getsentry sentry-javascript. EPSS estimates a 0.37% chance of exploitation in the next 30 days, higher than 30.8% of scored vulnerabilities.

Priority
Routine

Not severe (CVSS 5.1, network access); no exploitation reported by the 5 checked sources

Source freshness unavailable

How is this decided?
CVSS score
5.1/10
010
Medium · v4.0 (CVE.org)
EPSS score
0.37%
0%100%
Low · +0.03 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 0 · Related 1

Timeline

  1. 25-11-2025
    PublishedVulnerability first disclosed.
  2. 25-11-2025
    Last modifiedVulnerability information updated.

Description

Sentry-Javascript is an official Sentry SDKs for JavaScript. From version 10.11.0 to before 10.27.0, when a Node.js application using the Sentry SDK has sendDefaultPii: true it is possible to inadvertently send certain sensitive HTTP headers, including the Cookie header, to Sentry. Those headers would be stored within a Sentry organization as part of the associated trace. A person with access to the Sentry organization could then view and use these sensitive values to impersonate or escalate their privileges within the application. This issue has been patched in version 10.27.0.

CVSS metrics

3 scores · 3 sources · 1 version

EPSS trend

Probability

0.37%

Chance of exploitation in the next 30 days

Percentile

31%

Versus all other CVEs

30-day change

Increase +0.03 pp

From 0.34% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, administrative account, no user interaction (CVSS vector). Other conditions: not stated in public data.

@sentry12 products
  • astro≥ 10.11.0, < 10.27.0
  • aws-serverless≥ 10.11.0, < 10.27.0
  • bun≥ 10.11.0, < 10.27.0
  • google-cloud-serverless≥ 10.11.0, < 10.27.0
  • nestjs≥ 10.11.0, < 10.27.0
Getsentry1 product

2 vendors · 13 products

References

9 links