CVE-2025-68476: KEDA has Arbitrary File Read via Insufficient Path Validation in HashiCorp Vault Service Account Credential
Vulnerability summary
CVE-2025-68476 is a high (CVSS 8.2) vulnerability in kedacore keda. EPSS estimates a 0.63% chance of exploitation in the next 30 days, higher than 50% of scored vulnerabilities.
Not severe (CVSS 8.2, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 2 · Related 4Timeline
- 22-12-2025PublishedVulnerability first disclosed.
- 22-12-2025Last modifiedVulnerability information updated.
Description
KEDA is a Kubernetes-based Event Driven Autoscaling component. Prior to versions 2.17.3 and 2.18.3, an Arbitrary File Read vulnerability has been identified in KEDA, potentially affecting any KEDA resource that uses TriggerAuthentication to configure HashiCorp Vault authentication. The vulnerability stems from an incorrect or insufficient path validation when loading the Service Account Token specified in spec.hashiCorpVault.credential.serviceAccount. An attacker with permissions to create or modify a TriggerAuthentication resource can exfiltrate the content of any file from the node's filesystem (where the KEDA pod resides) by directing the file's content to a server under their control, as part of the Vault authentication request. The potential impact includes the exfiltration of sensitive system information, such as secrets, keys, or the content of files like /etc/passwd. This issue has been patched in versions 2.17.3 and 2.18.3.
CVSS metrics
5 scores · 5 sources · 1 version- OSV · WolfiEcosystem advisory · calculated8.2HighCVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N
- OSV · GoEcosystem advisory · calculated8.2HighCVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N
- OSV · ChainguardEcosystem advisory · calculated8.2HighCVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N
- NVDNIST8.2HighCVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
EPSS trend
Probability
0.63%
Chance of exploitation in the next 30 days
Percentile
50%
Versus all other CVEs
30-day change
Increase +0.07 pp
From 0.55% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root cause- CWE-22Improper Limitation of a Pathname to a Restricted DirectoryThe product uses external input to construct a pathname that is intended to identify a file or directory that is located underneath a restricted parent directory, but the product does not properly neutralize special elements within the pathname that can cause the pathname to resolve to a location that is outside of the restricted directory.
- CWE-863Incorrect AuthorizationThe product performs an authorization check when an actor attempts to access a resource or perform an action, but it does not correctly perform the check.
Affected systems
Known conditions: network-reachable, administrative account, no user interaction (CVSS vector). Other conditions: not stated in public data.
Chainguard23 products
- k8sgpt< 0.4.27-r1
- keda-2.16All versions (No fix recorded)
- keda-2.16-admission-webhooksAll versions (No fix recorded)
- keda-2.16-metrics-apiserverAll versions (No fix recorded)
- keda-fips-2.16All versions (No fix recorded)
Wolfi12 products
- k8sgpt< 0.4.27-r1
- kserve< 0.16.0-r7
- kserve-agent< 0.16.0-r7
- kserve-agent-compat< 0.16.0-r7
- kserve-manager< 0.16.0-r7
Github.com/kedacore1 product
- kedaAll versions (No fix recorded)
Github.com/kedacore/keda1 product
- v2< 2.17.3 | ≥ 2.18.0, < 2.18.3
Kedacore1 product
- keda< 2.17.3 | ≥ 2.18.0, < 2.18.3
5 vendors · 38 products
References
5 links- github.com/kedacore/kedaPACKAGE