CVE-2025-9519: Easy Timer <= 4.2.1 - Authenticated (Editor+) Remote Code Execution via Shortcode
Vulnerability summary
CVE-2025-9519 is a high (CVSS 7.2) Code Injection vulnerability in kleor easy timer. EPSS estimates a 0.91% chance of exploitation in the next 30 days, higher than 59.7% of scored vulnerabilities. Fixed in 4.2.2.
Timeline
- 04-09-2025PublishedVulnerability first disclosed.
- 08-04-2026Last modifiedVulnerability information updated.
Description
The Easy Timer plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 4.2.1 via the plugin's shortcodes. This is due to insufficient restriction of shortcode attributes. This makes it possible for authenticated attackers, with Editor-level access and above, to execute code on the server.
CVSS metrics
3 scores · 3 sources · 1 version- NVDNIST7.2HighCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- wordfenceSource7.2HighCVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
EPSS trend
Probability
0.91%
Chance of exploitation in the next 30 days
Percentile
60%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.91% on 28-09-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Kleor1 product
- easy timer≤ 4.2.1
Wordpress1 product
- easy-timer≤ 4.2.1 (fixed in 4.2.2)
2 vendors · 2 products