CVE-2025-9566: Podman: podman kube play command may overwrite host files
Vulnerability summary
CVE-2025-9566 is a high (CVSS 8.1) vulnerability in podman. EPSS estimates a 1.16% chance of exploitation in the next 30 days, higher than 67.2% of scored vulnerabilities.
Not severe (CVSS 8.1, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 21 · Related 19Timeline
- 05-09-2025PublishedVulnerability first disclosed.
- 03-11-2026Last modifiedVulnerability information updated.
Description
There's a vulnerability in podman where an attacker may use the kube play command to overwrite host files when the kube file container a Secrete or a ConfigMap volume mount and such volume contains a symbolic link to a host file path. In a successful attack, the attacker can only control the target file to be overwritten but not the content to be written into the file. Binary-Affected: podman Upstream-version-introduced: v4.0.0 Upstream-version-fixed: v5.6.1
CVSS metrics
8 scores · 8 sources · 1 version- OSV · Red hatEcosystem advisory · calculated8.1HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
- OSV · UbuntuEcosystem advisory · calculated8.1HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
- OSV · DebianEcosystem advisory · calculated8.1HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
- OSV · GoEcosystem advisory · calculated8.1HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
- OSV · ChainguardEcosystem advisory · calculated8.1HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
- NVDNIST8.1HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
- OSV · AlpineEcosystem advisory · calculated8.1HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
EPSS trend
Probability
1.16%
Chance of exploitation in the next 30 days
Percentile
67%
Versus all other CVEs
30-day change
Increase +0.05 pp
From 1.10% on 05-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, low-privilege account, no user interaction (CVSS vector). Other conditions: not stated in public data.
Redhat175 products
- aardvark-dns< 2:1.0.1-40.module+el8.6.0+22769+fa0fe772 | < 2:1.5.0-2.module+el8.8.0+22334+bb93e398
- bpftool< 0:7.3.0-427.87.1.el9_4 | < 0:7.0.0-284.138.1.el9_2
- bpftool-debuginfo< 0:7.3.0-427.87.1.el9_4 | < 0:7.0.0-284.138.1.el9_2
- buildah< 1:1.26.9-2.module+el8.6.0+23285+f8f75f94.1 | < 1:1.29.5-1.module+el8.8.0+23219+eb2ac228.1
- buildah-debuginfo< 1:1.26.9-2.module+el8.6.0+23285+f8f75f94.1 | < 1:1.29.5-1.module+el8.8.0+23219+eb2ac228.1
Suse12 products
- podman&distro=SUSE Enterprise Storage 7.1< 4.9.5-150300.9.55.1
- podman&distro=SUSE Linux Enterprise High Performance Computing 15 SP3-LTSS< 4.9.5-150300.9.55.1
- podman&distro=SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS< 4.9.5-150400.4.53.1
- podman&distro=SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS< 4.9.5-150400.4.53.1
- podman&distro=SUSE Linux Enterprise High Performance Computing 15 SP5-ESPOS< 4.9.5-150500.3.49.1
Github.com/containers/podman4 products
- v2All versions (No fix recorded)
- v3All versions (No fix recorded)
- v4All versions (No fix recorded) | ≤ 4.9.5
- v5< 5.6.1
Chainguard2 products
- prometheus-podman-exporter< 1.18.0-r2
- prometheus-podman-exporter-fips< 1.18.0-r2
Debian2 products
- libpodAll versions (No fix recorded)
- podmanAll versions (No fix recorded) | < 5.6.1+ds1-2
Ubuntu2 products
- libpodAll versions (No fix recorded)
- podmanAll versions (No fix recorded)
Alpine1 product
- podman< 5.6.1-r0
Github.com/containers1 product
- podmanAll versions (No fix recorded)
Opensuse1 product
- podman&distro=openSUSE Leap 15.6< 4.9.5-150500.3.49.1
9 vendors · 200 products · Showing 200 of 210
References
74 linksShow all 74 references
- github.com/containers/podmanPACKAGE