CVE-2026-13697: undici vulnerable to cross-user information disclosure and parse-time crash via degenerate private cache directives
Vulnerability summary
CVE-2026-13697 is a critical (CVSS 9.1) vulnerability in nodejs undici. EPSS estimates a 0.57% chance of exploitation in the next 30 days, higher than 47.1% of scored vulnerabilities.
Severe, CVSS 7.4 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 1% (FIRST, 03-11-2026)
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 2 · Related 1Timeline
- 29-07-2026PublishedVulnerability first disclosed.
- 29-07-2026Last modifiedVulnerability information updated.
Description
undici's cache interceptor mishandles malformed Cache-Control private directives. In undici 7.0.0 up to before 7.29.0 and 8.0.0 up to before 8.9.0, a response carrying a degenerate qualified private directive, such as private set to an empty value, can be stored in the default shared cache and later served to a different caller with the same cache key, disclosing private response bodies and headers including Set-Cookie. Separately, a Cache-Control header that combines an unqualified private directive with a qualified one triggers an uncaught TypeError in the cache-control parser, which rejects the request and, depending on the consumer's error handling, can terminate the process. Both issues affect applications using the cache interceptor in shared mode, including the default configuration. The issues are fixed in undici 7.29.0 and 8.9.0.
CVSS metrics
7 scores · 7 sources · 1 version- CVE.orgCNA7.4HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:HDiffers
- OSV · UbuntuEcosystem advisory · calculated9.1CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
- OSV · DebianEcosystem advisory · calculated9.1CriticalCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
- OSV · WolfiEcosystem advisory · calculated7.4HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:HDiffers
- OSV · NpmEcosystem advisory · calculated7.4HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:HDiffers
- OSV · ChainguardEcosystem advisory · calculated7.4HighCVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:HDiffers
EPSS trend
Probability
0.57%
Chance of exploitation in the next 30 days
Percentile
47%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.57% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root cause- CWE-200Exposure of Sensitive Information to an Unauthorized ActorThe product exposes sensitive information to an actor that is not explicitly authorized to have access to that information.
- CWE-248Uncaught ExceptionAn exception is thrown from a function, but it is not caught.
- CWE-525Use of Web Browser Cache Containing Sensitive InformationThe web application does not use an appropriate caching policy that specifies the extent to which each web page and associated form fields should be cached.
Affected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Chainguard28 products
- code-server< 4.130.0-r5
- commercial-gitlab-rails-ee-19.1< 19.1.7-r3
- commercial-gitlab-rails-ee-19.2< 19.2.7-r1
- commercial-gitlab-rails-ee-19.3< 19.3.3-r1
- commercial-gitlab-rails-ee-19.4< 19.4.1-r1
Wolfi7 products
- code-server< 4.130.0-r5
- langfuse-3< 3.225.0-r3
- langfuse-3-compat< 3.225.7-r6
- langfuse-3-worker< 3.225.0-r3
- renovate< 44.11.4-r0 | < 44.11.3-r0
Debian1 product
- node-undiciAll versions (No fix recorded) | < 8.9.0+dfsg+~cs3.2.0-1
Nodejs1 product
- undici≥ 7.0.0, < 7.29.0 | ≥ 8.0.0, < 8.9.0
Npm1 product
- undici≥ 7.0.0, < 7.29.0 | ≥ 8.0.0, < 8.9.0
Ubuntu1 product
- node-undiciAll versions (No fix recorded)
Undici1 product
- undici≥ 7.0.0, < 7.29.0 | ≥ 8.0.0, < 8.9.0
7 vendors · 40 products
References
11 links- github.com/nodejs/undici/security/advisories/GHSA-4cwx-7wf7-3272REPORTAdvisoryWEBMitigationVendor Advisory
- github.com/nodejs/undiciPACKAGE