CVE-2026-14257: brace-expansion DoS via unbounded expansion length causing an out-of-memory process crash
Vulnerability summary
CVE-2026-14257 is a high (CVSS 7.5) Uncontrolled Resource Consumption vulnerability in juliangruber brace-expansion. EPSS estimates a 0.64% chance of exploitation in the next 30 days, higher than 50.8% of scored vulnerabilities.
Severe, CVSS 7.5 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 1% (FIRST, 03-11-2026)
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 16 · Related 2Timeline
- 23-07-2026PublishedVulnerability first disclosed.
- 23-07-2026Last modifiedVulnerability information updated.
Description
brace-expansion through 5.0.7 is vulnerable to denial of service via memory exhaustion. The expand() function limits the number of results with a max option (default 100,000) but does not bound the length of each result string. By chaining multiple brace groups, an attacker keeps the result count under the limit while making each result progressively longer, so total memory scales with both count and string length until the process hits a fatal, uncatchable out-of-memory error. About 7.5 KB of input ('{a,b}'.repeat(1500)) crashes a default Node.js process. Any application that passes attacker-influenced strings to brace-expansion.expand() - directly or transitively via minimatch / glob brace patterns - can be crashed by a small request. Fixed in 5.0.8 by adding a maxLength option (default 4,000,000) that bounds accumulated output and intermediate arrays.
CVSS metrics
7 scores · 7 sources · 1 version- OSV · UbuntuEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- OSV · DebianEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- OSV · WolfiEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- OSV · NpmEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- OSV · ChainguardEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- NVDNIST7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS trend
Probability
0.64%
Chance of exploitation in the next 30 days
Percentile
51%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.64% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root cause- CWE-400Uncontrolled Resource ConsumptionThe product does not properly control the allocation and maintenance of a limited resource.
- CWE-770Allocation of Resources Without Limits or ThrottlingThe product allocates a reusable resource or group of resources on behalf of an actor without imposing any intended restrictions on the size or number of resources that can be allocated.
Affected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Chainguard148 products
- actions-runner< 2.336.0-r2
- airflow-2All versions (No fix recorded)
- airflow-core-2All versions (No fix recorded)
- arangodb-3.11< 3.11.14.4-r15 | < 3.11.14.4-r16
- arangodb-3.12< 3.12.9.4-r15
Wolfi34 products
- argo-workflows-ui-3.7< 3.7.17-r1
- argo-workflows-ui-4.0< 4.0.8-r2 | < 4.0.11-r0
- jupyter-base-notebook< 7.6.3-r2
- katib-suggestion-hyperopt< 0.19.0-r40
- langfuse-3-compat< 3.225.7-r6
Debian1 product
- node-brace-expansionAll versions (No fix recorded)
Juliangruber1 product
- brace-expansion≤ 5.0.7 | < 1.1.17 | ≥ 2.0.0, < 2.1.3 | ≥ 3.0.0, < 3.0.3 | ≥ 4.0.0, < 5.0.8
Npm1 product
- brace-expansion≥ 4.0.0, < 5.0.8 | ≥ 3.0.0, < 3.0.3 | ≥ 2.0.0, < 2.1.3 | < 1.1.17
Ubuntu1 product
- node-brace-expansionAll versions (No fix recorded)
6 vendors · 186 products