7.5

CVE-2026-14643: undici vulnerable to cross-user information disclosure via whitespace around equals in Cache-Control directives

Analyzed
AliasesUBUNTU-CVE-2026-14643DEBIAN-CVE-2026-14643CGA-2qw2-hwfc-6wq9
Published 29-07-2026Last modified 30-07-2026

Vulnerability summary

CVE-2026-14643 is a high (CVSS 7.5) Interpretation Conflict vulnerability in nodejs undici. EPSS estimates a 0.40% chance of exploitation in the next 30 days, higher than 33.8% of scored vulnerabilities.

Priority
Routine

Not severe (CVSS 5.9, network access); no exploitation reported by the 5 checked sources

Source freshness unavailable

How is this decided?
CVSS score
7.5/10
010
High · v3.1 (NVD)
EPSS score
0.40%
0%100%
Low · 0.00 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 2 · Related 1

Timeline

  1. 29-07-2026
    PublishedVulnerability first disclosed.
  2. 30-07-2026
    Last modifiedVulnerability information updated.

Description

undici's cache interceptor mishandles optional whitespace placed around the equals sign of a qualified no-cache or private Cache-Control directive. In undici from 7.0.0 up to before 7.29.0 and from 8.0.0 up to before 8.9.0, the parser either drops the directive or stores a field name with literal quote characters, so the cache decision fails to recognize the qualification and the response is stored. In shared-cache mode, this lets a response containing one user's authenticated data be served from cache to a later caller, including an unauthenticated one, when both requests resolve to the same cache key. It affects applications that enable the cache interceptor in shared mode, forward Authorization headers upstream, and receive cacheable responses with qualified directives padded with whitespace around the equals sign. This is the whitespace-around-equals variant that the fix for CVE-2026-9678 did not normalize, and it is fixed in undici 7.29.0 and 8.9.0.

CVSS metrics

7 scores · 7 sources · 1 version

EPSS trend

Probability

0.40%

Chance of exploitation in the next 30 days

Percentile

34%

Versus all other CVEs

30-day change

No change 0.00 pp

From 0.40% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.

Chainguard28 products
  • code-server< 4.130.0-r5
  • commercial-gitlab-rails-ee-19.1< 19.1.7-r3
  • commercial-gitlab-rails-ee-19.2< 19.2.7-r1
  • commercial-gitlab-rails-ee-19.3< 19.3.3-r1
  • commercial-gitlab-rails-ee-19.4< 19.4.1-r1
Wolfi7 products
  • code-server< 4.130.0-r5
  • langfuse-3< 3.225.0-r3
  • langfuse-3-compat< 3.225.7-r6
  • langfuse-3-worker< 3.225.0-r3
  • renovate< 44.11.4-r0 | < 44.11.3-r0
Debian1 product
  • node-undiciAll versions (No fix recorded) | < 8.9.0+dfsg+~cs3.2.0-1
Nodejs1 product
  • undici≥ 7.0.0, < 7.29.0 | ≥ 8.0.0, < 8.9.0
Npm1 product
  • undici≥ 7.0.0, < 7.29.0 | ≥ 8.0.0, < 8.9.0
Ubuntu1 product
  • node-undiciAll versions (No fix recorded)
Undici1 product
  • undici≥ 7.0.0, < 7.29.0 | ≥ 8.0.0, < 8.9.0

7 vendors · 40 products

References

12 links
Show all 12 references