6.5

CVE-2026-16728: undici vulnerable to downstream response desynchronization via retry interceptor

Analyzed
AliasesUBUNTU-CVE-2026-16728DEBIAN-CVE-2026-16728CGA-2869-jmhq-75g2
Published 29-07-2026Last modified 30-07-2026

Vulnerability summary

CVE-2026-16728 is a medium (CVSS 6.5) vulnerability in nodejs undici. EPSS estimates a 0.29% chance of exploitation in the next 30 days, higher than 21.4% of scored vulnerabilities.

Priority
Routine

Not severe (CVSS 4.8, network access); no exploitation reported by the 5 checked sources

Source freshness unavailable

How is this decided?
CVSS score
6.5/10
010
Medium · v3.1 (NVD)
EPSS score
0.29%
0%100%
Low · +0.11 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 6 · Related 5

Timeline

  1. 29-07-2026
    PublishedVulnerability first disclosed.
  2. 30-07-2026
    Last modifiedVulnerability information updated.

Description

undici's retry interceptor can deliver a response whose body length does not match the Content-Length header exposed to the application after a retry or resume of a partial response. In undici before 6.28.0, from 7.0.0 up to before 7.29.0, and from 8.0.0 up to before 8.9.0, a malicious or faulty upstream can return a partial response with a mismatched framing header, close the socket early, and have the retry interceptor assemble a body of a different length while the original Content-Length stays attached. Applications that use the retry interceptor and forward upstream headers and bodies downstream, such as proxies or gateways, may then emit an invalid HTTP response with a stale Content-Length, leading to downstream response desynchronization, connection hangs, or response corruption. Exploitation requires the retry interceptor enabled, an upstream returning a mismatched partial response, and a downstream forwarder that does not remove or recalculate Content-Length. The issue is fixed in undici 6.28.0, 7.29.0, and 8.9.0.

CVSS metrics

7 scores · 7 sources · 1 version

EPSS trend

Probability

0.29%

Chance of exploitation in the next 30 days

Percentile

21%

Versus all other CVEs

30-day change

Increase +0.11 pp

From 0.18% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.

Chainguard36 products
  • actions-runner< 2.336.0-r5
  • code-server< 4.130.0-r5
  • commercial-gitlab-rails-ee-19.1< 19.1.7-r3
  • commercial-gitlab-rails-ee-19.2< 19.2.7-r1
  • commercial-gitlab-rails-ee-19.3< 19.3.3-r1
Wolfi11 products
  • code-server< 4.130.0-r5
  • langfuse-3< 3.225.0-r3
  • langfuse-3-compat< 3.225.7-r6
  • langfuse-3-worker< 3.225.0-r3
  • npm-12< 12.0.2-r2
Debian1 product
  • node-undiciAll versions (No fix recorded) | < 8.9.0+dfsg+~cs3.2.0-1
Nodejs1 product
  • undici< 6.28.0 | ≥ 7.0.0, < 7.29.0 | ≥ 8.0.0, < 8.9.0
Npm1 product
  • undici< 6.28.0 | ≥ 7.0.0, < 7.29.0 | ≥ 8.0.0, < 8.9.0
Ubuntu1 product
  • node-undiciAll versions (No fix recorded)
Undici1 product
  • undici< 6.28.0 | ≥ 7.0.0, < 7.29.0 | ≥ 8.0.0, < 8.9.0

7 vendors · 52 products

References

18 links
Show all 18 references