3.7

CVE-2026-18540: undici vulnerable to downstream response splitting via retry interceptor

Analyzed
AliasesUBUNTU-CVE-2026-18540DEBIAN-CVE-2026-18540CGA-fxqw-f32h-wgqx
Published 04-09-2026Last modified 04-09-2026

Vulnerability summary

CVE-2026-18540 is a low (CVSS 3.7) vulnerability in nodejs undici. EPSS estimates a 0.31% chance of exploitation in the next 30 days, higher than 23.8% of scored vulnerabilities.

Priority
Routine

Not severe (CVSS 3.7, network access); no exploitation reported by the 5 checked sources

Source freshness unavailable

How is this decided?
CVSS score
3.7/10
010
Low · v3.1 (CVE.org)
EPSS score
0.31%
0%100%
Low · +0.07 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 3

Timeline

  1. 04-09-2026
    PublishedVulnerability first disclosed.
  2. 04-09-2026
    Last modifiedVulnerability information updated.

Description

undici's retry interceptor can append the body of a ranged retry response to bytes already delivered from an earlier partial response while still presenting the original response's status and headers. This happens when an upstream server delivers part of a body without a trustworthy resume checkpoint, for example a non-success response whose headers were already sent or a partial-content response with an unusable content range, then closes the connection and answers the resumed range request with more bytes. As a result the response body can be longer than the Content-Length that the application observes. An application that relays such a response to a downstream HTTP/1.1 peer without normalizing the framing can emit a body that exceeds the forwarded Content-Length, and the excess bytes can be interpreted as the start of a following response, which enables downstream response splitting or desynchronization. Exploitation requires an attacker-controlled upstream server and an application that forwards the response through a framing-sensitive path. This affects undici versions before 6.28.1, from 7.0.0 up to 7.29.1, and from 8.0.0 up to 8.10.2. Users should upgrade to undici 6.28.1, 7.29.1, or 8.10.2.

CVSS metrics

7 scores · 7 sources · 1 version

EPSS trend

Probability

0.31%

Chance of exploitation in the next 30 days

Percentile

24%

Versus all other CVEs

30-day change

Increase +0.07 pp

From 0.24% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.

Chainguard18 products
  • actions-runner< 2.337.0-r2
  • code-server< 4.139.1-r2
  • commercial-gitlab-rails-ee-19.1< 19.1.7-r3
  • commercial-gitlab-rails-ee-19.2< 19.2.7-r1
  • commercial-gitlab-rails-ee-19.3< 19.3.3-r1
Wolfi4 products
  • code-server< 4.139.1-r2
  • lernaAll versions (No fix recorded) | < 10.0.1-r11
  • prism< 5.16.0-r14
  • renovate< 44.131.0-r1 | < 44.133.0-r0
Debian1 product
  • node-undiciAll versions (No fix recorded) | < 8.10.2+dfsg+~cs3.2.2-1
Nodejs1 product
  • undici< 6.28.1 | ≥ 7.0.0, < 7.29.1 | ≥ 8.0.0, < 8.10.2
Npm1 product
  • undici< 6.28.1 | ≥ 7.0.0, < 7.29.1 | ≥ 8.0.0, < 8.10.2
Ubuntu1 product
  • node-undiciAll versions (No fix recorded)
Undici1 product
  • undici< 6.28.1 | ≥ 7.0.0, < 7.29.1 | ≥ 8.0.0, < 8.10.2

7 vendors · 27 products

References

16 links
Show all 16 references