7.5

CVE-2026-19534: undici vulnerable to Denial of Service via unrequested WebSocket subprotocol

Analyzed
AliasesUBUNTU-CVE-2026-19534DEBIAN-CVE-2026-19534CGA-2wf2-c9xx-f22h
Published 04-09-2026Last modified 04-09-2026

Vulnerability summary

CVE-2026-19534 is a high (CVSS 7.5) Uncaught Exception vulnerability in nodejs undici. EPSS estimates a 0.39% chance of exploitation in the next 30 days, higher than 33.6% of scored vulnerabilities.

Priority
Prioritisesevere

Severe, CVSS 7.5 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 0% (FIRST, 03-11-2026)

Source freshness unavailable

How is this decided?
CVSS score
7.5/10
010
High · v3.1 (CVE.org)
EPSS score
0.39%
0%100%
Low · 0.00 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 11

Timeline

  1. 04-09-2026
    PublishedVulnerability first disclosed.
  2. 04-09-2026
    Last modifiedVulnerability information updated.

Description

undici's WebSocket client crashes the whole Node.js process during the opening handshake when a server responds with a subprotocol that the client never requested. A default WebSocket connection sends no subprotocol, but if the server's 101 response includes a Sec-WebSocket-Protocol header, undici dereferences a null value while checking it against the requested list and throws an uncaught TypeError. Because that code runs inside a microtask with no surrounding error handling, the exception propagates and terminates the process under Node's default behavior, instead of gracefully failing the connection as required by the WebSocket protocol. Any application that opens a WebSocket to an attacker-controlled or compromised server, or over a plaintext connection subject to a machine-in-the-middle, can be crashed remotely without authentication in the default configuration. This affects undici versions from 6.7.0 up to 6.28.1, from 7.0.0 up to 7.29.1, and from 8.0.0 up to 8.10.2. Users should upgrade to undici 6.28.1, 7.29.1, or 8.10.2.

CVSS metrics

7 scores · 7 sources · 1 version

EPSS trend

Probability

0.39%

Chance of exploitation in the next 30 days

Percentile

34%

Versus all other CVEs

30-day change

No change 0.00 pp

From 0.39% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.

Chainguard16 products
  • actions-runner< 2.337.0-r2
  • code-server< 4.139.1-r2
  • commercial-gitlab-rails-ee-19.1< 19.1.7-r3
  • commercial-gitlab-rails-ee-19.2< 19.2.7-r1
  • commercial-gitlab-rails-ee-19.3< 19.3.3-r1
Wolfi4 products
  • code-server< 4.139.1-r2
  • lernaAll versions (No fix recorded) | < 10.0.1-r11
  • prism< 5.16.0-r14
  • renovate< 44.133.0-r0 | < 44.131.0-r1
Debian1 product
  • node-undiciAll versions (No fix recorded) | < 8.10.2+dfsg+~cs3.2.2-1
Nodejs1 product
  • undici≥ 6.7.0, < 6.28.1 | ≥ 7.0.0, < 7.29.1 | ≥ 8.0.0, < 8.10.2
Npm1 product
  • undici≥ 6.7.0, < 6.28.1 | ≥ 7.0.0, < 7.29.1 | ≥ 8.0.0, < 8.10.2
Ubuntu1 product
  • node-undiciAll versions (No fix recorded)
Undici1 product
  • undici≥ 6.7.0, < 6.28.1 | ≥ 7.0.0, < 7.29.1 | ≥ 8.0.0, < 8.10.2

7 vendors · 25 products

References

14 links
Show all 14 references