CVE-2026-23632: Gogs user can update repository content with read-only permission
Vulnerability summary
CVE-2026-23632 is a medium (CVSS 6.5) Missing Authorization vulnerability in gogs. EPSS estimates a 0.31% chance of exploitation in the next 30 days, higher than 24.2% of scored vulnerabilities.
Not severe (CVSS 6.5, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 2 · Related 2Timeline
- 06-02-2026PublishedVulnerability first disclosed.
- 06-02-2026Last modifiedVulnerability information updated.
Description
Gogs is an open source self-hosted Git service. In version 0.13.3 and prior, the endpoint "PUT /repos/:owner/:repo/contents/*" does not require write permissions and allows access with read permission only via repoAssignment(). After passing the permission check, PutContents() invokes UpdateRepoFile(), which results in commit creation and the execution of git push. As a result, a token with read-only permission can be used to modify repository contents. This issue has been patched in versions 0.13.4 and 0.14.0+dev.
CVSS metrics
3 scores · 3 sources · 1 version- OSV · GoEcosystem advisory · calculated6.5MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
- NVDNIST6.5MediumCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
EPSS trend
Probability
0.31%
Chance of exploitation in the next 30 days
Percentile
24%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.32% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root cause- CWE-862Missing AuthorizationThe product does not perform an authorization check when an actor attempts to access a resource or perform an action.
- CWE-863Incorrect AuthorizationThe product performs an authorization check when an actor attempts to access a resource or perform an action, but it does not correctly perform the check.
Affected systems
Known conditions: network-reachable, low-privilege account, no user interaction (CVSS vector). Other conditions: not stated in public data.
Gogs1 product
- gogs< 0.14.0+dev | < 0.13.4
Gogs.io1 product
- gogs< 0.13.4 | All versions (No fix recorded)
2 vendors · 2 products
References
5 links- github.com/gogs/gogs/security/advisories/GHSA-5qhx-gwfj-6jqrX Refsource CONFIRMWEBAdvisoryVendor Advisory
- github.com/gogs/gogsPACKAGE