9.2

CVE-2026-25547: Uncontrolled Resource Consumption in @isaacs/brace-expansion

Deferred
AliasesUBUNTU-CVE-2026-25547DEBIAN-CVE-2026-25547CGA-22m9-3mhh-rjx8
Published 04-02-2026Last modified 05-02-2026

Vulnerability summary

CVE-2026-25547 is a critical (CVSS 9.2) vulnerability in isaacs brace-expansion. EPSS estimates a 0.54% chance of exploitation in the next 30 days, higher than 45.3% of scored vulnerabilities.

Priority
Prioritisesevere

Severe, CVSS 9.2 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 1% (FIRST, 03-11-2026)

Source freshness unavailable

How is this decided?
CVSS score
9.2/10
010
Critical · v4.0 (CVE.org)
EPSS score
0.54%
0%100%
Low · +0.04 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 37 · Related 31

Timeline

  1. 04-02-2026
    PublishedVulnerability first disclosed.
  2. 05-02-2026
    Last modifiedVulnerability information updated.

Description

@isaacs/brace-expansion is a hybrid CJS/ESM TypeScript fork of brace-expansion. Prior to version 5.0.1, @isaacs/brace-expansion is vulnerable to a denial of service (DoS) issue caused by unbounded brace range expansion. When an attacker provides a pattern containing repeated numeric brace ranges, the library attempts to eagerly generate every possible combination synchronously. Because the expansion grows exponentially, even a small input can consume excessive CPU and memory and may crash the Node.js process. This issue has been patched in version 5.0.1.

CVSS metrics

7 scores · 7 sources · 1 version

EPSS trend

Probability

0.54%

Chance of exploitation in the next 30 days

Percentile

45%

Versus all other CVEs

30-day change

Increase +0.04 pp

From 0.50% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.

Chainguard11 products
  • actions-runner< 2.331.0-r3
  • authentik-2025.12All versions (No fix recorded)
  • authentik-fips-2025.12All versions (No fix recorded)
  • drupal-11.3< 11.3.13-r1
  • lerna< 9.0.3-r3
Opensuse11 products
  • cockpit-machines&distro=openSUSE Tumbleweed< 348-1.1
  • cockpit-packages&distro=openSUSE Tumbleweed< 4.1-4.1
  • cockpit-podman&distro=openSUSE Tumbleweed< 120-2.1
  • cockpit-repos&distro=openSUSE Tumbleweed< 4.7-4.1
  • cockpit-subscriptions&distro=openSUSE Tumbleweed< 14.4-4.1
Wolfi6 products
  • lerna< 9.0.3-r3
  • node-gyp< 12.2.0-r2
  • npm< 11.9.0-r0
  • pulumi-language-nodejs< 3.217.1-r2
  • renovate< 43.3.1-r0 | < 43.2.4-r0
@isaacs1 product
  • brace-expansion< 5.0.1
Debian1 product
  • node-brace-expansionAll versions (No fix recorded) | < 2.0.3+~1.1.2-2
Isaacs1 product
Ubuntu1 product
  • node-brace-expansionAll versions (No fix recorded)

7 vendors · 32 products

References

9 links