CVE-2026-32597: PyJWT accepts unknown `crit` header extensions (RFC 7515 §4.1.11 MUST violation)
Vulnerability summary
CVE-2026-32597 is a high (CVSS 7.5) vulnerability in jpadilla pyjwt. EPSS estimates a 0.28% chance of exploitation in the next 30 days, higher than 20.4% of scored vulnerabilities. 1 public exploit is recorded.
Public exploit (GitHub, Date unknown)
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 12 · Related 3Timeline
- 12-03-2026PublishedVulnerability first disclosed.
- 10-09-2026Last modifiedVulnerability information updated.
Description
PyJWT is a JSON Web Token implementation in Python. Prior to 2.12.0, PyJWT does not validate the crit (Critical) Header Parameter defined in RFC 7515 §4.1.11. When a JWS token contains a crit array listing extensions that PyJWT does not understand, the library accepts the token instead of rejecting it. This violates the MUST requirement in the RFC. This vulnerability is fixed in 2.12.0.
CVSS metrics
7 scores · 7 sources · 1 version- OSV · PypiEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- OSV · UbuntuEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- OSV · DebianEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- OSV · WolfiEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- OSV · ChainguardEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- NVDNIST7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS trend
Probability
0.28%
Chance of exploitation in the next 30 days
Percentile
20%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.28% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
1 foundPyjwt
Maturity: poc
Weaknesses
CWE · root cause- CWE-345Insufficient Verification of Data AuthenticityThe product does not sufficiently verify the origin or authenticity of data, in a way that causes it to accept invalid data.
- CWE-863Incorrect AuthorizationThe product performs an authorization check when an actor attempts to access a resource or perform an action, but it does not correctly perform the check.
- CWE-347Improper Verification of Cryptographic SignatureThe product does not verify, or incorrectly verifies, the cryptographic signature for data.
Affected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Chainguard39 products
- airflow-2< 2.11.2-r2
- airflow-3< 3.1.8-r8
- airflow-core-2< 2.11.2-r1
- airflow-core-3< 3.1.8-r1
- authentik< 2026.2.1-r4
Suse19 products
- python-PyJWT&distro=SUSE Linux Enterprise High Performance Computing 15 SP4-ESPOS< 2.4.0-150200.3.11.1 | < 2.8.0-150400.8.10.1
- python-PyJWT&distro=SUSE Linux Enterprise High Performance Computing 15 SP4-LTSS< 2.4.0-150200.3.11.1 | < 2.8.0-150400.8.10.1
- python-PyJWT&distro=SUSE Linux Enterprise High Performance Computing 15 SP5-ESPOS< 2.4.0-150200.3.11.1 | < 2.8.0-150400.8.10.1
- python-PyJWT&distro=SUSE Linux Enterprise High Performance Computing 15 SP5-LTSS< 2.4.0-150200.3.11.1 | < 2.8.0-150400.8.10.1
- python-PyJWT&distro=SUSE Linux Enterprise Micro 5.5< 2.4.0-150200.3.11.1
Wolfi14 products
- airflow-3< 3.1.8-r8
- az< 2.84.0-r3
- datadog-agent-7.72-core-integrationsAll versions (No fix recorded)
- datadog-agent-7.73-core-integrations< 7.73.3-r23
- datadog-agent-7.74-core-integrations< 7.74.1-r24
Opensuse4 products
- python-PyJWT&distro=openSUSE Leap 15.6< 2.8.0-150400.8.10.1
- python-PyJWT&distro=openSUSE Leap 16.0< 2.12.1-160000.1.1
- python-PyJWT&distro=openSUSE Tumbleweed< 2.12.1-1.1
- python-social-auth-core&distro=openSUSE Tumbleweed< 4.8.7-1.1
Debian1 product
- pyjwt< 2.6.0-1+deb12u1 | < 2.10.1-2+deb13u1 | < 2.12.1-1
Jpadilla1 product
- pyjwt< 2.12.0
Pyjwt_project1 product
- pyjwt< 2.12.0
PyPI1 product
- pyjwt< 2.12.0
Ubuntu1 product
- pyjwt< 1.3.0-1ubuntu0.1+esm1 | < 1.5.3+ds1-1ubuntu0.1+esm1 | < 1.7.1-2ubuntu2.1+esm1 | < 2.3.0-1ubuntu0.3 | < 2.7.0-1ubuntu0.1 | < 2.10.1-2ubuntu0.1
9 vendors · 81 products
References
51 links- github.com/jpadilla/pyjwt/security/advisories/GHSA-752w-5fwx-jx9fX Refsource CONFIRMWEBEVIDENCEAdvisoryExploitMitigationVendor Advisory
Show all 51 references
- github.com/jpadilla/pyjwtPACKAGE