CVE-2026-35611: Addressable has a Regular Expression Denial of Service in Addressable templates
Vulnerability summary
CVE-2026-35611 is a high (CVSS 7.5) vulnerability in addressable_project addressable. EPSS estimates a 0.36% chance of exploitation in the next 30 days, higher than 29.8% of scored vulnerabilities.
Severe, CVSS 7.5 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 0% (FIRST, 03-11-2026)
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 0 · Related 1Timeline
- 07-04-2026PublishedVulnerability first disclosed.
- 09-04-2026Last modifiedVulnerability information updated.
Description
Addressable is an alternative implementation to the URI implementation that is part of Ruby's standard library. From 2.3.0 to before 2.9.0, within the URI template implementation in Addressable, two classes of URI template generate regular expressions vulnerable to catastrophic backtracking. Templates using the * (explode) modifier with any expansion operator (e.g., {foo*}, {+var*}, {#var*}, {/var*}, {.var*}, {;var*}, {?var*}, {&var*}) generate patterns with nested unbounded quantifiers that are O(2^n) when matched against a maliciously crafted URI. Templates using multiple variables with the + or # operators (e.g., {+v1,v2,v3}) generate patterns with O(n^k) complexity due to the comma separator being within the matched character class, causing ambiguous backtracking across k variables. When matched against a maliciously crafted URI, this can result in catastrophic backtracking and uncontrolled resource consumption, leading to denial of service. This vulnerability is fixed in 2.9.0.
CVSS metrics
8 scores · 8 sources · 1 version- OSV · UbuntuEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- OSV · DebianEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- OSV · WolfiEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- OSV · ChainguardEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- OSV · RubygemsEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- NVDNIST7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- OSV · AlpineEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS trend
Probability
0.36%
Chance of exploitation in the next 30 days
Percentile
30%
Versus all other CVEs
30-day change
Decrease -0.10 pp
From 0.46% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Chainguard64 products
- cinc-auditor< 7.0.107-r3
- gitlab-rails-ce-18.1All versions (No fix recorded)
- gitlab-rails-ce-18.10All versions (No fix recorded)
- gitlab-rails-ce-18.11All versions (No fix recorded)
- gitlab-rails-ce-18.2All versions (No fix recorded)
Wolfi10 products
- cinc-auditor< 7.0.107-r3
- kube-fluentd-operator< 1.18.2-r69
- kube-logging-operator-fluentd-outputs< 6.4.0-r11
- logstash-9.3< 9.3.3-r2
- logstash-9.3-iamguarded-compat< 9.3.3-r2
Addressable_project1 product
- addressable≥ 2.3.0, < 2.9.0
Alpine1 product
- ruby-addressable≥ 2.3.0, < 2.9.0-r0
Debian1 product
- ruby-addressableAll versions (No fix recorded) | < 2.9.0-1
RubyGems1 product
- addressable≥ 2.3.0, < 2.9.0
Sporkmonger1 product
- addressable≥ 2.3.0, < 2.9.0
Ubuntu1 product
- ruby-addressable< 2.3.8-1ubuntu0.1~esm1 | < 2.5.2-1ubuntu0.1~esm1 | < 2.7.0-1ubuntu0.1~esm1 | < 2.8.0-3ubuntu0.1~esm1 | < 2.8.5-1ubuntu0.1~esm1 | All versions (No fix recorded) | < 2.8.7-2ubuntu0.26.04.1~esm1
8 vendors · 80 products
References
13 links- github.com/sporkmonger/addressable/security/advisories/GHSA-h27x-rffw-24p4X Refsource CONFIRMREPORTAdvisoryWEBMitigationVendor Advisory