CVE-2026-41432: New API: Stripe Webhook Signature Bypass via Empty Secret Enables Unlimited Quota Fraud
Vulnerability summary
CVE-2026-41432 is a high (CVSS 8.2) vulnerability in newapi new_api. EPSS estimates a 0.85% chance of exploitation in the next 30 days, higher than 58.2% of scored vulnerabilities. 1 public exploit is recorded.
Public exploit (GitHub, Date unknown)
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 1 · Related 1Timeline
- 08-05-2026PublishedVulnerability first disclosed.
- 12-05-2026Last modifiedVulnerability information updated.
Description
New API is a large language mode (LLM) gateway and artificial intelligence (AI) asset management system. Prior to version 0.12.10, a vulnerability exists in the Stripe webhook handler that allows an unauthenticated attacker to forge webhook events and credit arbitrary quota to their account without making any payment. This issue has been patched in version 0.12.10.
CVSS metrics
3 scores · 3 sources · 1 version- CVE.orgCNA7.1HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:LDiffers
- OSV · GoEcosystem advisory · calculated7.1HighCVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:LDiffers
EPSS trend
Probability
0.85%
Chance of exploitation in the next 30 days
Percentile
58%
Versus all other CVEs
30-day change
Increase +0.10 pp
From 0.75% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
1 foundNew Api
Maturity: poc
Weaknesses
CWE · root cause- CWE-345Insufficient Verification of Data AuthenticityThe product does not sufficiently verify the origin or authenticity of data, in a way that causes it to accept invalid data.
- CWE-863Incorrect AuthorizationThe product performs an authorization check when an actor attempts to access a resource or perform an action, but it does not correctly perform the check.
- CWE-1188Initialization of a Resource with an Insecure DefaultThe product initializes or sets a resource with a default that is intended to be changed by the product's installer, administrator, or maintainer, but the default is not secure.
Affected systems
Known conditions: network-reachable, low-privilege account, no user interaction (CVSS vector). Other conditions: not stated in public data.
Github.com/QuantumNous1 product
- new-api< 0.12.10
Newapi1 product
- new_api< 0.12.10
Quantumnous1 product
- new-api< 0.12.10
3 vendors · 3 products
References
6 links- github.com/QuantumNous/new-api/security/advisories/GHSA-xff3-5c9p-2mr4X Refsource CONFIRMWEBAdvisoryExploitMitigationVendor Advisory