CVE-2026-42570: Svelte devalue: DoS via sparse array deserialization
Vulnerability summary
CVE-2026-42570 is a high (CVSS 7.5) vulnerability in svelte devalue. EPSS estimates a 0.40% chance of exploitation in the next 30 days, higher than 33.9% of scored vulnerabilities.
Severe, CVSS 7.5 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 0% (FIRST, 03-11-2026)
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 1Timeline
- 09-06-2026PublishedVulnerability first disclosed.
- 24-08-2026Last modifiedVulnerability information updated.
Description
Svelte devalue is a JavaScript library that serializes values into strings when JSON.stringify isn't sufficient for the job. From version 5.6.3 to before version 5.8.1, devalue.parse could, due to quirks in some JavaScript engines, be convinced to allocate much more memory than was needed when deserializing sparse arrays, leading to excessive memory consumption. This issue has been patched in version 5.8.1.
CVSS metrics
3 scores · 3 sources · 1 version- OSV · NpmEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- NVDNIST7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS trend
Probability
0.40%
Chance of exploitation in the next 30 days
Percentile
34%
Versus all other CVEs
30-day change
Decrease -0.32 pp
From 0.72% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Npm1 product
- devalue≥ 5.6.3, < 5.8.1
Svelte1 product
- devalue≥ 5.6.3, < 5.8.1
Sveltejs1 product
- devalue≥ 5.6.3, < 5.8.1
3 vendors · 3 products
References
10 links- github.com/sveltejs/devalue/security/advisories/GHSA-77vg-94rm-hx3pX Refsource CONFIRMWEBVendor Advisory
- github.com/sveltejs/devaluePACKAGE