CVE-2026-44160: Fluentd: Denial of Service (DoS) via Gzip Decompression Bomb in `in_http` and `in_forward`
Vulnerability summary
CVE-2026-44160 is a high (CVSS 7.5) vulnerability in fluent fluentd. EPSS estimates a 0.62% chance of exploitation in the next 30 days, higher than 49.7% of scored vulnerabilities.
Severe, CVSS 7.5 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 1% (FIRST, 03-11-2026)
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 0 · Related 1Timeline
- 08-07-2026PublishedVulnerability first disclosed.
- 09-07-2026Last modifiedVulnerability information updated.
Description
Fluentd collects events from various data sources and writes them to files, RDBMS, NoSQL, IaaS, SaaS, Hadoop and so on. Prior to 1.19.3, Fluentd's in_http and in_forward plugins support gzip-compressed data but enforce limits only on compressed payloads through settings such as body_size_limit and chunk_size_limit, allowing crafted compressed payloads to decompress in memory to an excessive size and cause denial of service through memory exhaustion. This issue is fixed in version 1.19.3.
CVSS metrics
5 scores · 5 sources · 1 version- OSV · WolfiEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- OSV · ChainguardEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- OSV · RubygemsEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- NVDNIST7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS trend
Probability
0.62%
Chance of exploitation in the next 30 days
Percentile
50%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.62% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Chainguard27 products
- kube-fluentd-operator< 1.18.2-r72
- ruby3.2-fluentd-1.16All versions (No fix recorded)
- ruby3.2-fluentd-1.17All versions (No fix recorded)
- ruby3.2-fluentd-1.18All versions (No fix recorded)
- ruby3.2-fluentd-kubernetes-daemonset-1.16-kinesisAll versions (No fix recorded)
Wolfi10 products
- kube-fluentd-operator< 1.18.2-r72
- ruby3.2-fluentd-kubernetes-daemonset-1.19-kinesis< 1.19.2.1.1-r5
- ruby3.2-kube-logging-operator-fluentd-outputs< 6.7.0-r7
- ruby3.3-fluentd-1.17All versions (No fix recorded)
- ruby3.3-fluentd-kubernetes-daemonset-1.19-kinesis< 1.19.3.1.0-r0
Fluent1 product
- fluentd< 1.19.3
Fluentd1 product
- fluentd< 1.19.3
RubyGems1 product
- fluentd< 1.19.3
5 vendors · 40 products
References
7 links- github.com/fluent/fluentd/security/advisories/GHSA-j9cw-hwqf-85w7X Refsource CONFIRMAdvisoryWEBMitigationVendor Advisory
- github.com/fluent/fluentdPACKAGE