2.7

CVE-2026-44162: fluent-plugin-s3: Denial of Service (DoS) via Decompression Bomb in `in_s3`

Deferred
AliasesCGA-3x63-wxc6-w3gqCGA-887g-jx9w-fj93CGA-9hwc-9464-rx3c
Published 14-09-2026Last modified 14-09-2026

Vulnerability summary

CVE-2026-44162 is a low (CVSS 2.7) vulnerability in fluent fluent-plugin-s3. EPSS estimates a 0.48% chance of exploitation in the next 30 days, higher than 41.6% of scored vulnerabilities.

Priority
Routine

Not severe (CVSS 2.7, network access); no exploitation reported by the 5 checked sources

Source freshness unavailable

How is this decided?
CVSS score
2.7/10
010
Low · v3.1 (CVE.org)
EPSS score
0.48%
0%100%
Low · 0.00 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 0 · Related 1

Timeline

  1. 14-09-2026
    PublishedVulnerability first disclosed.
  2. 14-09-2026
    Last modifiedVulnerability information updated.

Description

fluent-plugin-s3 is an Amazon S3 input and output plugin for Fluentd. From 0.7.0 to 1.8.4, the in_s3 input plugin reads the entire decompressed payload of gzip, lzma2, and lzop objects into memory without enforcing a decompression_size_limit. An attacker with permission to upload objects to the monitored S3 bucket can provide a highly compressed object that expands excessively when Fluentd processes it. The resulting memory exhaustion can cause the operating system to terminate the Fluentd process and disrupt all log collection on the affected node. This issue is fixed in version 1.8.5.

CVSS metrics

5 scores · 5 sources · 1 version

EPSS trend

Probability

0.48%

Chance of exploitation in the next 30 days

Percentile

42%

Versus all other CVEs

30-day change

No change 0.00 pp

From 0.48% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, administrative account, no user interaction (CVSS vector). Other conditions: not stated in public data.

Chainguard2 products
  • ruby3.2-kube-logging-operator-fluentd-outputs< 6.7.0-r5
  • ruby3.4-kube-logging-operator-fluentd-outputs< 6.7.0-r5
Wolfi2 products
  • ruby3.2-kube-logging-operator-fluentd-outputs< 6.7.0-r5
  • ruby3.4-kube-logging-operator-fluentd-outputs< 6.7.0-r5
Fluent1 product
RubyGems1 product
  • fluent-plugin-s3≥ 0.7.0, < 1.8.5

4 vendors · 6 products

References

4 links