CVE-2026-44166: Pocketbase: Account pre-hijacking via OAuth2 unverfied->verified autolinking upgrade
Vulnerability summary
CVE-2026-44166 is a high (CVSS 7.6) Improper Authentication vulnerability in pocketbase. EPSS estimates a 0.25% chance of exploitation in the next 30 days, higher than 16% of scored vulnerabilities.
Not severe (CVSS 6.1, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 4 · Related 4Timeline
- 12-05-2026PublishedVulnerability first disclosed.
- 12-05-2026Last modifiedVulnerability information updated.
Description
Pocketbase is an open source web backend written in go. Prior to 0.22.42 and 0.37.4, in some situations, if an attacker knows the email address of the victim they can create and link an unverified PocketBase user in advance by authenticating with one of the OAuth2 app providers, e.g. "A". When the victim gets invited or decides to sign up to your app on their own with provider "B" (PocketBase OAuth2 auth requires to be with a different provider because we don't allow multiple OAuth2 accounts from the same provider to be associated to a single PocketBase user), the user created previously by the attacker will be autolinked, upgraded to "verified" and its old password reset. This vulnerability is fixed in 0.22.42 and 0.37.4.
CVSS metrics
4 scores · 3 sources · 2 versions- OSV · GoEcosystem advisory · calculated6.1MediumCVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:H/VA:L/SC:N/SI:N/SA:N
- NVDNIST6.1MediumCVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:H/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
EPSS trend
Probability
0.25%
Chance of exploitation in the next 30 days
Percentile
16%
Versus all other CVEs
30-day change
Decrease -0.07 pp
From 0.32% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, no authentication, user interaction (CVSS vector). Other conditions: not stated in public data.
Github.com/pocketbase1 product
- pocketbase< 0.22.42 | ≥ 0.30.0, < 0.37.4
Pocketbase1 product
- pocketbase≥ 0.30.0, < 0.37.4 | < 0.22.42 | ≥ 0.23.0, < 0.37.4
2 vendors · 2 products
References
4 links- github.com/pocketbase/pocketbase/security/advisories/GHSA-pq7p-mc74-g65wX Refsource CONFIRMWEBAdvisoryVendor Advisory