CVE-2026-54272: ip-address: Misclassification of IPv4-mapped/NAT64 IPv6 addresses can bypass SSRF and trust-boundary checks
Vulnerability summary
CVE-2026-54272 is a medium (CVSS 6.9) Improper Input Validation vulnerability in beaugunderson ip-address. EPSS estimates a 0.40% chance of exploitation in the next 30 days, higher than 34.4% of scored vulnerabilities.
Not severe (CVSS 6.9, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 16 · Related 12Timeline
- 27-07-2026PublishedVulnerability first disclosed.
- 27-07-2026Last modifiedVulnerability information updated.
Description
ip-address is a library for parsing and manipulating IPv4 and IPv6 addresses in JavaScript. Versions 10.1.1 through 10.2.0 are vulnerable to SSRF through misclassification of IPv4-mapped/NAT64 IPv6 addresses. Address6.getType() classifies an address by matching it against a table of known IPv6 special-use prefixes, returning Global unicast when nothing matches. That table had no entry for the IPv4-mapped range (::ffff:0:0/96), so every mapped address fell through to Global unicast; NAT64 addresses matched their own NAT64 … labels. The boolean checks isLoopback, isUnspecified, and isMulticast compared getType() against a fixed label and so returned false, while isLinkLocal and isULA checked only the native IPv6 ranges. The library already exposed isMapped4() and to4(), but did not apply them inside these checks, so a mapped or NAT64 address was never normalized to its embedded IPv4 address before classification. For IPv4-mapped addresses the host OS routes to the IPv4 stack, so the misclassification is reachable on any dual-stack host. For NAT64, the classification bypass is unconditional but end-to-end reachability additionally requires a NAT64/DNS64 gateway in the deployment network.This issue has been fixed in version 10.2.1.
CVSS metrics
7 scores · 7 sources · 1 version- OSV · UbuntuEcosystem advisory · calculated6.9MediumCVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:H/SI:N/SA:N
- OSV · DebianEcosystem advisory · calculated6.9MediumCVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:H/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
- OSV · WolfiEcosystem advisory · calculated6.9MediumCVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:H/SI:N/SA:N
- OSV · NpmEcosystem advisory · calculated6.9MediumCVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:H/SI:N/SA:N
- OSV · ChainguardEcosystem advisory · calculated6.9MediumCVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:H/SI:N/SA:N
- NVDNIST6.9MediumCVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:H/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
EPSS trend
Probability
0.40%
Chance of exploitation in the next 30 days
Percentile
34%
Versus all other CVEs
30-day change
Decrease -0.03 pp
From 0.43% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root cause- CWE-20Improper Input ValidationThe product receives input or data, but it does not validate or incorrectly validates that the input has the properties that are required to process the data safely and correctly.
- CWE-918Server-Side Request ForgeryThe web server receives a URL or similar request from an upstream component and retrieves the contents of this URL, but it does not sufficiently ensure that the request is being sent to the expected destination.
Affected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Chainguard34 products
- actions-runner< 2.336.0-r5
- code-server< 4.130.0-r6
- graalvm-25-ce-nodejs< 25.0.4-r15
- kibana-9.3< 9.3.8-r6
- kibana-9.3-iamguardedAll versions (No fix recorded)
Wolfi14 products
- code-server< 4.130.0-r6
- kubeflow-pipelines-apiserver< 2.17.2-r4
- kubeflow-pipelines-frontend< 2.17.0-r3
- kubeflow-pipelines-metadata-writer-compat< 2.17.2-r4
- langfuse-3-compat< 3.225.7-r6
Opensuse2 products
- nodejs24&distro=openSUSE Tumbleweed< 24.21.0-1.1
- nodejs26&distro=openSUSE Tumbleweed< 26.7.0-1.1
Beaugunderson1 product
- ip-address≥ 10.1.1, < 10.2.1
Debian1 product
- node-ip-address< 10.3.1-1
Npm1 product
- ip-address≥ 10.1.1, < 10.2.1
Ubuntu1 product
- node-ip-addressAll versions (No fix recorded)
7 vendors · 54 products
References
10 links- github.com/beaugunderson/ip-address/security/advisories/GHSA-22jq-vg5j-6vggX Refsource CONFIRMAdvisoryWEB