7.5

CVE-2026-54874: Excessive Memory Use Buffering DTLS Records for a Future Epoch

Analyzed
AliasesALPINE-CVE-2026-54874UBUNTU-CVE-2026-54874DEBIAN-CVE-2026-54874
Published 25-08-2026Last modified 25-08-2026

Vulnerability summary

CVE-2026-54874 is a high (CVSS 7.5) vulnerability in openssl. EPSS estimates a 0.62% chance of exploitation in the next 30 days, higher than 49.8% of scored vulnerabilities.

Priority
Prioritisesevere

Severe, CVSS 7.5 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 1% (FIRST, 03-11-2026)

Source freshness unavailable

How is this decided?
CVSS score
7.5/10
010
High · v3.1 (CVE.org)
EPSS score
0.62%
0%100%
Low · 0.00 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 23 · Related 18

Timeline

  1. 25-08-2026
    PublishedVulnerability first disclosed.
  2. 25-08-2026
    Last modifiedVulnerability information updated.

Description

Issue summary: Receiving a DTLS record for a future epoch while a handshake is in progress causes OpenSSL to buffer far more memory than the record itself requires. Impact summary: A peer can use a small amount of network traffic to make an OpenSSL DTLS endpoint retain a disproportionately large amount of memory, which may lead to a Denial of Service. CWE: CWE-405: Asymmetric Resource Consumption (Amplification) Description: While a DTLS handshake is in progress, a peer may legitimately have already moved on to the next epoch (for example, having sent its ChangeCipherSpec and Finished messages) before the local endpoint has processed the same transition, typically because of reordering on the underlying UDP transport. OpenSSL buffers such early records so that they can be processed once the local endpoint catches up. Buffering a record currently retains the entire read buffer it arrived in, which is sized to hold the largest possible DTLS record (around 16 kilobytes), rather than just the bytes that make up the record itself. Up to 100 such records may be buffered per connection. As a result, a peer that sends a stream of small forged records claiming to belong to the next epoch can cause an OpenSSL DTLS endpoint to retain around 1.7 megabytes of memory, despite sending only a small fraction of that amount of data over the network. An attacker therefore gains a memory amplification factor of around 1200, and can multiply the effect across as many associations as it is able to open, making this a remote memory exhaustion Denial of Service risk for DTLS servers. Since the memory retained per connection remains bounded, and any limit an application already places on the number of concurrent associations also bounds the total exposure, this issue has been assessed as Low severity. FIPS impact: no No FIPS modules are affected by this issue as the affected code is outside the OpenSSL FIPS module boundary. OpenSSL 4.0, 3.6, 3.5, 3.4, 3.0, 1.1.1 and 1.0.2 are vulnerable to this issue. OpenSSL 4.0 users should upgrade to OpenSSL 4.0.2. OpenSSL 3.6 users should upgrade to OpenSSL 3.6.4. OpenSSL 3.5 users should upgrade to OpenSSL 3.5.8. OpenSSL 3.4 users should upgrade to OpenSSL 3.4.7. OpenSSL 3.0 users should upgrade to OpenSSL 3.0.22. Premium support customers only: OpenSSL 1.1.1 users should upgrade to OpenSSL 1.1.1zi OpenSSL 1.0.2 users should upgrade to OpenSSL 1.0.2zr This issue was reported on 18 May 2026 by Amazon Web Services. The fix has been developed by Matt Caswell. -- cut (non-publishing metadata for internal use) -- Reported by: Amazon Web Services Fixed by: Matt Caswell

CVSS metrics

7 scores · 7 sources · 1 version

EPSS trend

Probability

0.62%

Chance of exploitation in the next 30 days

Percentile

50%

Versus all other CVEs

30-day change

No change 0.00 pp

From 0.62% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.

Chainguard15 products
  • eco-dotnet-libssl-1.0All versions (No fix recorded)
  • eco-python-openssl-4< 4.0.2-r0
  • eco-python-openssl-4-pyca< 4.0.2-r0
  • eco-python-openssl-4-pyca-dev< 4.0.2-r0
  • openssl-3.5< 3.5.8-r0
Ubuntu6 products
  • edk2< 0~20160408.ffea0a2c-2ubuntu0.2+esm4 | < 0~20180205.c0d9813c-2ubuntu0.3+esm3 | < 0~20191122.bd85bf54-2ubuntu3.6+esm1 | < 2022.02-3ubuntu0.22.04.7 | < 2024.02-2ubuntu0.10 | All versions (No fix recorded) | < 2025.11-3ubuntu7.3
  • edk2-hweAll versions (No fix recorded)
  • nodejsAll versions (No fix recorded)
  • openssl< 1.0.1f-1ubuntu2.27+esm16 | < 1.0.2g-1ubuntu4.20+esm18 | All versions (No fix recorded) | < 1.1.1-1ubuntu2.1~18.04.23+esm10 | < 1.1.1f-1ubuntu2.24+esm5 | < 3.0.2-0ubuntu1.29 | < 3.0.2-0ubuntu1.29+Fips1 | < 3.0.13-0ubuntu3.15 | < 3.5.5-1ubuntu3.4
  • openssl-fipsAll versions (No fix recorded) | < 3.0.13-0ubuntu3.15+Fips1
Wolfi3 products
  • openssl-4.0< 4.0.2-r0
  • openssl-4.0-libcrypto< 4.0.2-r0
  • openssl-4.0-libssl< 4.0.2-r0
Suse2 products
  • openssl-1_0_0&distro=SUSE Linux Enterprise Server 12 SP5-LTSS< 1.0.2p-3.115.1
  • openssl-1_0_0&distro=SUSE Linux Enterprise Server LTSS Extended Security 12 SP5< 1.0.2p-3.115.1
Alpine1 product
  • openssl≥ 1.0.2, < 3.5.8-r0
Debian1 product
  • openssl< 3.0.22-1~deb12u1 | < 3.5.7-1~deb13u2 | < 3.6.4-1
Openssl1 product
  • openssl≥ 1.0.2, < 1.0.2zr | ≥ 1.1.1, < 1.1.1zi | ≥ 3.0.0, < 3.0.22 | ≥ 3.4.0, < 3.4.7 | ≥ 3.5.0, < 3.5.8 | ≥ 3.6.0, < 3.6.4 | ≥ 4.0.0, < 4.0.2

7 vendors · 29 products

References

19 links
Show all 19 references