7.5

CVE-2026-59870: js-yaml quadratic-complexity denial of service via YAML11_SCHEMA !!omap parsing

Modified
AliasesUBUNTU-CVE-2026-59870CGA-gc2h-vr93-w9f3CGA-j5v6-64xq-v6v4
Published 08-07-2026Last modified 06-10-2026

Vulnerability summary

CVE-2026-59870 is a high (CVSS 7.5) Inefficient Algorithmic Complexity vulnerability in nodeca js-yaml. EPSS estimates a 0.74% chance of exploitation in the next 30 days, higher than 54.6% of scored vulnerabilities. 1 public exploit is recorded.

Priority
Prioritisepublic exploit

Public exploit (GitHub, Date unknown)

Source freshness unavailable

How is this decided?
CVSS score
7.5/10
010
High · v3.1 (CVE.org)
EPSS score
0.74%
0%100%
Low · +0.10 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits1github

Advisory lineage

Upstream 0 · Downstream 8 · Related 1

Timeline

  1. 08-07-2026
    PublishedVulnerability first disclosed.
  2. 06-10-2026
    Last modifiedVulnerability information updated.

Description

js-yaml is a JavaScript YAML parser and dumper. Prior to 3.15.1, 4.3.1, and 5.2.1, YAML11_SCHEMA support for the !!omap tag in src/tag/sequence/omap.ts uses omapTag.addItem() to perform a linear duplicate-key scan on every insertion, causing O(n^2) CPU consumption when yaml.load() parses a crafted ordered-map document. In v3 and v4, !!omap is active and exploitable by default. v5 doesn't use !!omap by default, and the chances of activating it are very low.This issue is fixed in 3.15.1, 4.3.1, and 5.2.1.

CVSS metrics

6 scores · 6 sources · 1 version

EPSS trend

Probability

0.74%

Chance of exploitation in the next 30 days

Percentile

55%

Versus all other CVEs

30-day change

Increase +0.10 pp

From 0.64% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

1 found
  • githubUnverified

    Js Yaml

    Maturity: poc

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.

Chainguard1 product
  • renovate< 44.3.3-r0 | < 44.3.2-r0
Nodeca1 product
  • js-yaml≥ 3.0.0, < 3.15.1 | ≥ 4.0.0, < 4.3.1 | ≥ 5.0.0, < 5.2.1
Npm1 product
  • js-yaml≥ 5.0.0, < 5.2.1
Ubuntu1 product
  • node-js-yamlAll versions (No fix recorded)
Wolfi1 product
  • renovate< 44.3.3-r0 | < 44.3.2-r0

5 vendors · 5 products

References

12 links
Show all 12 references