CVE-2026-65640: wordpress
Vulnerability summary
CVE-2026-65640 is a high (CVSS 8.8) vulnerability in wordpress. EPSS estimates a 1.94% chance of exploitation in the next 30 days, higher than 80.1% of scored vulnerabilities. Fixed in 4.7.35.
Not severe (CVSS 8.8, network access); no exploitation reported by the 5 checked sources
Source freshness unavailable
How is this decided?Timeline
- 17-08-2026PublishedVulnerability first disclosed.
- 18-08-2026Last modifiedVulnerability information updated.
Description
WordPress is vulnerable to a remote code execution vulnerability via malicious Postscript file upload by an Author level user or higher. Prerequisites: * Imagick and Ghostscript in use on the server * A malicious user with the `upload_files` capability This issue affects all versions of WordPress. Version 7.0.4 has been released, containing a fix for the vulnerability, and as a courtesy to users on older branches the fix has been backported to all branches back to 4.7.
CVSS metrics
5 scores · 5 sources · 2 versions- OSV · UbuntuEcosystem advisory · calculated8.8HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- OSV · DebianEcosystem advisory · calculated8.8HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- NVDNIST8.8HighCVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS trend
Probability
1.94%
Chance of exploitation in the next 30 days
Percentile
80%
Versus all other CVEs
30-day change
No change 0.00 pp
From 1.94% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root causeAffected systems
Known conditions: network-reachable, low-privilege account, no user interaction (CVSS vector). Other conditions: not stated in public data.
Wordpress2 products
- wordpress≥ 4.7.0, ≤ 4.7.34 (fixed in 4.7.35) | ≥ 4.8.0, ≤ 4.8.29 (fixed in 4.7.35) | ≥ 4.9.0, ≤ 4.9.30 (fixed in 4.7.35) | ≥ 5.0.0, ≤ 5.0.26 (fixed in 4.7.35) | ≥ 5.1.0, ≤ 5.1.23 (fixed in 4.7.35) | ≥ 5.2.0, ≤ 5.2.25 (fixed in 4.7.35) | ≥ 5.3.0, ≤ 5.3.22 (fixed in 4.7.35) | ≥ 5.4.0, ≤ 5.4.20 (fixed in 4.7.35) | ≥ 5.5.0, ≤ 5.5.19 (fixed in 4.7.35) | ≥ 5.6.0, ≤ 5.6.18 (fixed in 4.7.35) | ≥ 5.7.0, ≤ 5.7.16 (fixed in 4.7.35) | ≥ 5.8.0, ≤ 5.8.14 (fixed in 4.7.35) | ≥ 5.9.0, ≤ 5.9.15 (fixed in 4.7.35) | ≥ 6.0.0, ≤ 6.0.13 (fixed in 4.7.35) | ≥ 6.1.0, ≤ 6.1.11 (fixed in 4.7.35) | ≥ 6.2.0, ≤ 6.2.10 (fixed in 4.7.35) | ≥ 6.3.0, ≤ 6.3.9 (fixed in 4.7.35) | ≥ 6.4.0, ≤ 6.4.9 (fixed in 4.7.35) | ≥ 6.5.0, ≤ 6.5.9 (fixed in 4.7.35) | ≥ 6.6.0, ≤ 6.6.6 (fixed in 4.7.35) | ≥ 6.7.0, ≤ 6.7.6 (fixed in 4.7.35) | ≥ 6.8.0, ≤ 6.8.7 (fixed in 4.7.35) | ≥ 6.9.0, ≤ 6.9.6 (fixed in 4.7.35) | ≥ 7.0.0, ≤ 7.0.3 (fixed in 4.7.35)
- wordpress< 7.0.4
Debian1 product
- wordpressAll versions (No fix recorded) | < 6.8.10+dfsg1-0+deb13u1 | < 7.1+dfsg1-1
Ubuntu1 product
- wordpressAll versions (No fix recorded)
3 vendors · 4 products