7.5

CVE-2026-75899: fast-uri vulnerable to server-side request forgery via repeated hostname percent-decoding

Analyzed
AliasesUBUNTU-CVE-2026-75899DEBIAN-CVE-2026-75899CGA-27rr-v9p9-wfxf
Published 24-08-2026Last modified 24-08-2026

Vulnerability summary

CVE-2026-75899 is a high (CVSS 7.5) Double Decoding of the Same Data vulnerability in fast-uri. EPSS estimates a 0.22% chance of exploitation in the next 30 days, higher than 12.6% of scored vulnerabilities.

Priority
Prioritisesevere

Severe, CVSS 7.5 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 0% (FIRST, 03-11-2026)

Source freshness unavailable

How is this decided?
CVSS score
7.5/10
010
High · v3.1 (CVE.org)
EPSS score
0.22%
0%100%
Low · 0.00 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 5 · Related 1

Timeline

  1. 24-08-2026
    PublishedVulnerability first disclosed.
  2. 24-08-2026
    Last modifiedVulnerability information updated.

Description

fast-uri is a URI parser for Node.js. It decodes percent escapes in a hostname during parsing and then decodes the parsed hostname a second time during authority recomposition, so a single call to normalize or resolve can turn nested percent-encoded input into a different network destination such as a loopback hostname or address. For example, a doubly encoded host that spells out a loopback name decodes to that live host in one operation, which contradicts RFC 3986 section 2.4 that an implementation must not decode the same string more than once. An application that normalizes or resolves an untrusted HTTP-family URI before outbound routing, redirect validation, or a host-policy check can receive a destination different from the one the original encoded host represented, giving a server-side request forgery and host-policy bypass primitive. This is an incomplete-fix variant of CVE-2026-6322. The affected versions are 2.4.1 up to but not including 2.4.5, 3.1.2 up to but not including 3.1.6, and 4.0.0 up to but not including 4.1.3. The issue is fixed in 2.4.5, 3.1.6, and 4.1.3, which normalize percent escapes once and preserve encoded percent signs. Users should upgrade to a patched version.

CVSS metrics

7 scores · 7 sources · 1 version

EPSS trend

Probability

0.22%

Chance of exploitation in the next 30 days

Percentile

13%

Versus all other CVEs

30-day change

No change 0.00 pp

From 0.22% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.

Chainguard71 products
  • arangodb-3.12< 3.12.11-r1
  • argo-workflows-ui-4.0< 4.0.11-r0
  • gitlab-rails-ce-fips-19.1< 19.1.7-r5
  • jupyter-base-notebook< 7.6.3-r2
  • keep-ui< 0.54.2-r8
Wolfi21 products
  • argo-workflows-ui-4.0< 4.0.11-r0
  • jupyter-base-notebook< 7.6.3-r2
  • nextcloud-server-32< 32.0.14-r1
  • opensearch-dashboards-3< 3.8.0-r1
  • opensearch-dashboards-3-alerting-dashboards-plugin< 3.8.0-r1
Debian1 product
  • node-ajvAll versions (No fix recorded) | < 8.20.0~ds+~cs7.1.4-1
Fast-uri1 product
  • fast-uri≥ 2.4.1, < 2.4.5 | ≥ 3.1.2, < 3.1.6 | ≥ 4.0.0, < 4.1.3
Npm1 product
  • fast-uri≥ 2.4.1, < 2.4.5 | ≥ 3.1.2, < 3.1.6 | ≥ 4.0.0, < 4.1.3
Openjsf1 product
  • fast-uri≥ 2.4.1, < 2.4.5 | ≥ 3.1.2, < 3.1.6 | ≥ 4.0.0, < 4.1.3
Ubuntu1 product
  • node-ajvAll versions (No fix recorded)

7 vendors · 97 products

References

14 links
Show all 14 references