CVE-2026-75975: fast-uri vulnerable to server-side request forgery via malformed IPv6 normalization
Vulnerability summary
CVE-2026-75975 is a high (CVSS 7.5) Improper Input Validation vulnerability in fast-uri. EPSS estimates a 0.22% chance of exploitation in the next 30 days, higher than 12.6% of scored vulnerabilities.
Severe, CVSS 7.5 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 0% (FIRST, 03-11-2026)
Source freshness unavailable
How is this decided?Advisory lineage
Upstream 0 · Downstream 5 · Related 1Timeline
- 24-08-2026PublishedVulnerability first disclosed.
- 24-08-2026Last modifiedVulnerability information updated.
Description
fast-uri is a URI parser for Node.js. Its custom parser for bracketed IPv6 literals does not validate the complete IPv6 grammar, so invalid trailing text in an authority can be silently discarded and a malformed attacker-controlled host is turned into a different valid IPv6 destination. For example, a bracketed literal with invalid trailing characters is normalized to the unspecified address, which a Node HTTP client then connects to a local service over loopback, and other malformed literals collapse to private-range addresses. No error is set on the parsed result, so an application checking the error field cannot detect the rewrite. An application that normalizes untrusted URLs before outbound requests, redirects, proxy routing, or address-policy enforcement can be redirected to a local or private IPv6 target, giving a server-side request forgery and address-policy bypass primitive. The affected versions are 2.3.1 up to but not including 2.4.5, 3.0.0 up to but not including 3.1.6, and 4.0.0 up to but not including 4.1.3. The issue is fixed in 2.4.5, 3.1.6, and 4.1.3, which validate bracketed IP literals against the full grammar and mark malformed literals as authority errors. Users should upgrade to a patched version.
CVSS metrics
7 scores · 7 sources · 1 version- OSV · UbuntuEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- OSV · DebianEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- OSV · WolfiEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- OSV · NpmEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- OSV · ChainguardEcosystem advisory · calculated7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
- NVDNIST7.5HighCVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N
EPSS trend
Probability
0.22%
Chance of exploitation in the next 30 days
Percentile
13%
Versus all other CVEs
30-day change
No change 0.00 pp
From 0.22% on 04-10-2026
Known exploited
Compare KEV catalogsNot in the CISA KEV catalog.
Not in the ENISA CNW catalog.
Not in the CIRCL catalog.
Public exploits
0 foundNo public exploits indexed.
Weaknesses
CWE · root cause- CWE-20Improper Input ValidationThe product receives input or data, but it does not validate or incorrectly validates that the input has the properties that are required to process the data safely and correctly.
- CWE-918Server-Side Request ForgeryThe web server receives a URL or similar request from an upstream component and retrieves the contents of this URL, but it does not sufficiently ensure that the request is being sent to the expected destination.
Affected systems
Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.
Chainguard94 products
- airflow-2All versions (No fix recorded)
- airflow-core-2All versions (No fix recorded)
- arangodb-3.12< 3.12.11-r1
- argo-workflows-ui-4.0< 4.0.11-r0
- commercial-gitlab-rails-ee-19.1< 19.1.7-r3
Wolfi21 products
- argo-workflows-ui-4.0< 4.0.11-r0
- jupyter-base-notebook< 7.6.3-r2
- nextcloud-server-32< 32.0.14-r1
- opensearch-dashboards-3< 3.8.0-r1
- opensearch-dashboards-3-alerting-dashboards-plugin< 3.8.0-r1
Debian1 product
- node-ajvAll versions (No fix recorded) | < 8.20.0~ds+~cs7.1.4-1
Fast-uri1 product
- fast-uri≥ 2.3.1, < 2.4.5 | ≥ 3.0.0, < 3.1.6 | ≥ 4.0.0, < 4.1.3
Npm1 product
- fast-uri≥ 2.3.1, < 2.4.5 | ≥ 3.0.0, < 3.1.6 | ≥ 4.0.0, < 4.1.3
Openjsf1 product
- fast-uri≥ 2.3.1, < 2.4.5 | ≥ 3.0.0, < 3.1.6 | ≥ 4.0.0, < 4.1.3
Ubuntu1 product
- node-ajvAll versions (No fix recorded)
7 vendors · 120 products
References
14 links- github.com/fastify/fast-uri/security/advisories/GHSA-f65p-4m7j-42xcREPORTAdvisoryWEBMitigationVendor Advisory