7.5

CVE-2026-76172: fast-uri vulnerable to host confusion via percent-encoded scheme normalization

Analyzed
AliasesUBUNTU-CVE-2026-76172DEBIAN-CVE-2026-76172CGA-235x-hm2p-83h6
Published 24-08-2026Last modified 24-08-2026

Vulnerability summary

CVE-2026-76172 is a high (CVSS 7.5) vulnerability in fast-uri. EPSS estimates a 0.23% chance of exploitation in the next 30 days, higher than 14.1% of scored vulnerabilities.

Priority
Prioritisesevere

Severe, CVSS 7.5 (CVE.org); no exploitation reported by the 5 checked sources; EPSS 0% (FIRST, 03-11-2026)

Source freshness unavailable

How is this decided?
CVSS score
7.5/10
010
High · v3.1 (CVE.org)
EPSS score
0.23%
0%100%
Low · 0.00 pp in 30 days
KEVNot listedNot listed by any tracked catalog.
RansomwareNot flaggedNo ransomware use recorded.
Public exploits0No public exploits recorded

Advisory lineage

Upstream 0 · Downstream 4 · Related 1

Timeline

  1. 24-08-2026
    PublishedVulnerability first disclosed.
  2. 24-08-2026
    Last modifiedVulnerability information updated.

Description

fast-uri is a URI parser for Node.js. During parsing it runs a legacy decoding pass over the scheme component and never re-escapes the result, and serialization writes the scheme back out verbatim, unlike the host component which is re-escaped. As a result an input whose scheme carries percent-encoded slashes parses as a scheme with no authority, so the parsed host and error are both undefined, yet resolving or normalizing that same input emits a network-path reference whose authority is attacker-chosen and re-parses to that host. An application that allowlists on the parsed host, or treats a reference with no authority as safe to resolve against its base, gets the opposite of what it checked, giving an off-site redirect, server-side request forgery, or address-policy bypass. The legacy decoder also expands non-standard escape forms, widening the issue past upstream filters, and control characters in the scheme can reach the output as raw carriage return and line feed. The affected versions are 2.3.1 up to but not including 2.4.5, 3.0.0 up to but not including 3.1.6, and 4.0.0 up to but not including 4.1.3. The issue is fixed in 2.4.5, 3.1.6, and 4.1.3, which reject a scheme that is not valid after decoding. Users should upgrade to a patched version.

CVSS metrics

7 scores · 7 sources · 1 version

EPSS trend

Probability

0.23%

Chance of exploitation in the next 30 days

Percentile

14%

Versus all other CVEs

30-day change

No change 0.00 pp

From 0.23% on 04-10-2026

04-10-202603-11-2026

Known exploited

Compare KEV catalogs
CISA KEV

Not in the CISA KEV catalog.

ENISA CNW

Not in the ENISA CNW catalog.

CIRCL

Not in the CIRCL catalog.

Public exploits

0 found

No public exploits indexed.

Weaknesses

CWE · root cause

Affected systems

Version check

Known conditions: network-reachable, no authentication, no user interaction (CVSS vector). Other conditions: not stated in public data.

Chainguard94 products
  • airflow-2All versions (No fix recorded)
  • airflow-core-2All versions (No fix recorded)
  • arangodb-3.12< 3.12.11-r1
  • argo-workflows-ui-4.0< 4.0.11-r0
  • commercial-gitlab-rails-ee-19.1< 19.1.7-r3
Wolfi21 products
  • argo-workflows-ui-4.0< 4.0.11-r0
  • jupyter-base-notebook< 7.6.3-r2
  • nextcloud-server-32< 32.0.14-r1
  • opensearch-dashboards-3< 3.8.0-r1
  • opensearch-dashboards-3-alerting-dashboards-plugin< 3.8.0-r1
Debian1 product
  • node-ajvAll versions (No fix recorded) | < 8.20.0~ds+~cs7.1.4-1
Fast-uri1 product
  • fast-uri≥ 2.3.1, < 2.4.5 | ≥ 3.0.0, < 3.1.6 | ≥ 4.0.0, < 4.1.3
Npm1 product
  • fast-uri≥ 2.3.1, < 2.4.5 | ≥ 3.0.0, < 3.1.6 | ≥ 4.0.0, < 4.1.3
Openjsf1 product
  • fast-uri≥ 2.3.1, < 2.4.5 | ≥ 3.0.0, < 3.1.6 | ≥ 4.0.0, < 4.1.3
Ubuntu1 product
  • node-ajvAll versions (No fix recorded)

7 vendors · 120 products

References

14 links
Show all 14 references